browser_aboutHome_behavior.js leaks global windows when --run-by-dir

REOPENED
Assigned to

Status

()

REOPENED
4 years ago
4 years ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

unspecified
Firefox 36
All
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
in bug 1082133 we refactored the tests to have the aboutHome portion of the search behavior tests in a separate file.  The original intention was to do this and disable it until we could fix it.  Luckily this works pretty well for all platforms, but is a perma fail on windows 7 and 8 (not xp) when we run tests in --run-by-dir mode.

You can look at comment 26 - 31 to see that we tried adjusting timeouts and it didn't help much.

I suspect there is something fishy going on here, maybe something related to aboutHome or something we can do in the test case.
(Assignee)

Comment 2

4 years ago
this test is now disabled in all cases, luckily it is a combination of subtests so we are not disabling much functionality.
(In reply to Joel Maher (:jmaher) from comment #2)
> this test is now disabled in all cases, luckily it is a combination of
> subtests so we are not disabling much functionality.

I thought the leak problem was only on Windows? did I read it wrong?
Why is it not just disabled on Windows?
(Assignee)

Comment 4

4 years ago
once this was live, we had a couple instances on linux and a couple on osx.  Windows was 100% failure, these others were >20% failure.

If you have further ideas on how I could aid in getting to the root cause or narrow this down, I would be happy to work on it!
https://hg.mozilla.org/mozilla-central/rev/82dfe4ee980b
Assignee: nobody → jmaher
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
(Assignee)

Comment 6

4 years ago
forgot to mark this as leave-open
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: browser_aboutHome_behavior.js leaks on windows 7+8 opt|debug runs when --run-by-dir → browser_aboutHome_behavior.js leaks global windows when --run-by-dir
You need to log in before you can comment on or make changes to this bug.