Closed Bug 1100497 Opened 5 years ago Closed 4 years ago

Intermittent test_animation.html | timing out after 120000ms. Animated image still doesn't look correct, after poll #2090

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: RyanVM, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Seth promises me he'll fix within a day or disable the test :)

08:09:03     INFO -  1404 INFO TEST-START | chrome://mochitests/content/chrome/image/test/mochitest/test_animation.html
08:10:25     INFO -  JavaScript error: resource://app/modules/WindowsJumpLists.jsm, line 525: ReferenceError: _idle is not defined
08:11:03     INFO -  1405 INFO TEST-PASS | chrome://mochitests/content/chrome/image/test/mochitest/test_animation.html | Reference snapshot shouldn't match clean (non-image) snapshot
08:11:03     INFO -  1406 INFO TEST-PASS | chrome://mochitests/content/chrome/image/test/mochitest/test_animation.html | Reference image should disappear when it becomes display:none
08:11:03     INFO -  1407 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/image/test/mochitest/test_animation.html | timing out after 120000ms.  Animated image still doesn't look correct, after poll #2090 - expected PASS
08:11:03     INFO -  1408 INFO TEST-OK | chrome://mochitests/content/chrome/image/test/mochitest/test_animation.html | took 120069ms
Flags: needinfo?(seth)
This is currently believed to have been triggered by one of these bugs:

Bug 1089046, bug 1097405, bug 1097431, bug 1097432, bug 1098108.
Flags: needinfo?(seth)
I am most suspicious of bug 1089046 and bug 1097405 (the first two).
We're disabling in the morning if we can't figure it out by then, but Seth is adding some extra assertions to hopefully help diagnose things overnight.
Flags: needinfo?(kwierso)
To build on that, I think this is similar to another bug that I've seen happen with some of my try pushes that was triggered by a failure to report all the progress changes and invalidations a decoder produced before shutting it down. (Unfortunately, unlike that one, I could not reproduce this one locally.)

Odds are good that the regressing bug is bug 1089046, if that explanation is accurate.

My plan is to:

1. Write a patch to fix all known ways that that can happen.
2. Add assertions that should confirm the cause if it happens again.
3. Wait until it happens a couple more times. Otherwise I won't be able to tell if the problem is fixed and whether my theory is correct.
Depends on: 1100725
Bug 1100725 has the patches.
OK, I just pushed the patches for bug 1100725. It's possible that those patches fix this issue, but if they don't, please wait until we hit it a couple times before disabling. (If the problem is what I suspect it is, if we *do* hit it again, it'll take the form of an assertion in Decoder.cpp.)
I'm going to wait for some other things to land before trying to fix this again. I'll needinfo myself as a reminder to come back to this, though.
Flags: needinfo?(seth)
Depends on: 1103439
Alright, I have a new theory as to the cause here. Bug 1103439 will fix this if my theory is correct. I'm going to try reenabling 'test_animation.html' after that patch lands.
Depends on: 1262269
Bug 1262269 re-enabled this test. So far so good.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(seth)
Resolution: --- → WORKSFORME
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.