noaa.gov - Javascript failure on login attempt

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: ekihn, Assigned: bc)

Tracking

Details

(Whiteboard: [USERAGENT][PROPRIETARY-DOM], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011113
BuildID:    20011113

When trying to login in on http://spidr.ngdc.noaa.gov/ the Javascript fails
under Mozilla, where as Netscape 4.x and IE 5.X seem to work fine.
For testing use the anonymous login.

Reproducible: Always
Steps to Reproduce:
1. load http://spidr.ngdc.noaa.gov/
2. choose "login" as anonymous on left panel
3. Main panel changes (indicating login) but left panel does not update

Actual Results:  Failed to update login panel.

Expected Results:  The left panel should be filled with a new menu. This works
fine under Netscape 4.X and IE 5.x.
Reporter
This is not mozilla's fault because the server send us document.Layer

JS Console:
Error: document.layers has no properties
Source File: http://spidr.ngdc.noaa.gov/spidr/toolbar.html
Line: 62


-> Evangelism
Assignee: rogerl → bclary
Status: UNCONFIRMED → NEW
Component: Javascript Engine → English: US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → zach
Version: other → unspecified

Comment 2

17 years ago
Note: NN4.7 supported layers, but they are not W3C-standard HTML,
and are not supported in Mozilla/N6. <DIVS> should be used instead.
For a good reference on this, see

http://devedge.netscape.com/evangelism/docs/articles/updating-dhtml-web-pages
(Assignee)

Comment 3

17 years ago
Eric, do you understand the problem? Do you need further assistance ?
Marking assigned since the reporter is [a|the] owner.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Priority: -- → P3
Hardware: PC → All
Summary: Javascript failure on login attempt → noaa.gov - Javascript failure on login attempt
Whiteboard: [USERAGENT][PROPRIETARY-DOM]
Target Milestone: --- → Jan

Comment 4

17 years ago
mass resassign of all gov sites to the gov component. You may filter for 
these changes by searching for the string 
'wehaveagreatgovernmentintheusa'
Status: ASSIGNED → NEW
Component: US General → US Gov
QA Contact: zach → chrisn
Target Milestone: Jan → ---
(Assignee)

Updated

17 years ago
Keywords: evang500
menu is now a JSP and fails with 500, but only for Mozilla

Comment 6

16 years ago
WFM, 2003032004/Win2K
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

16 years ago
tech evang june 2003 reorg
Component: US Gov → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.