randomly marks old read messages as unread.

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Kent Harker, Unassigned)

Tracking

31 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2015-12-10])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

I am using an imap server. I can't reproduce, it just randomly marks old read messages as unread. There is not any consistent number of messages marked, sometimes just a few but today it marked over 1700 as unread in one folder. 


Actual results:

I can't reproduce, it just randomly marks old read messages as unread. There is not any consistent number of messages marked, sometimes just a few but today it marked over 1700 as unread in one folder. 


Expected results:

Any message marked as read should remain marked as read.
For imap case:

In imap, Read / Unread == with \Seen flag / without \Seen flag, and the \Seen flag is held at server.
Any imap client who accesses the same imap folder can store \Seen flag of a mail, and can remove \Seen flag of a mail.
After you marked a mail as Read by your Tb(==store \Seen flag), other imap client, including Web mail, including imap server himself, removed \Seen flag, didn't it?
Is there evidence data(for example, imap log in Tb) for next?
   After you marked a mail as Read by your Tb(store \Seen flag), your Tb randomly removed \Seen flag from mail.
Your Thunderbird is only one mail client who accesses the imap folder?

Because there is problem of Bug 693204, "flag status change by other imap client" is not immediately notified to Tb, so "flag status change by other imap client" may be seen "random" for you. 

Another case.

Your imap server doesn't support \Seen flag, so Tb holds "\Seen status" locally in xxx.msf file.
After it, synchronization with imap server is lost and xxx.msf is cleared, or xxx.msf file was somehow deleted or cleared in your environment, so all mail status is obtained from imap server again.
Because \Seen flag is not held by your imap server, mail is shown as "Unread".

Does your imap server support \Seen flag?

For local mail folder case:

Tb has Bug 840418. So, if mail is marked by "Mark Folder Read", mail's status is changed back to Unread if Rebuild-Index(Repair Folder) is done intentionally or accidentally.

Comment 2

2 years ago
kent do you still see this problem?
If you do, there are two questions for you in comment 1.
Flags: needinfo?(khark)
Whiteboard: [closeme 2015-12-10]
(Reporter)

Comment 3

2 years ago
I have not had the problem for a long time.
Flags: needinfo?(khark)

Comment 4

2 years ago
Thanks for the update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.