Rocketbar completely broken in landscape mode with private browsing window.

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: gwagner, Unassigned)

Tracking

unspecified
2.2 S1 (5dec)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Rocketbar/status bar is currently completely broken on master with private browsing and landscape mode.
We can't land new features without basic testing.
(Reporter)

Updated

5 years ago
Assignee: nobody → kgrandon
Hey Gregor - we definitely tested in landscape, so this is a surprise. Can you detail what you are seeing? I checked again and I didn't see anything related to the private browsing landed that broke this.

I *am* seeing a lot of bad regressions in landscape in general though - things that don't have anything to do with private browsing. It seems like some statusbar work, or possibly platform work has broken some things on trunk. I'm seeing:

- Square corners.
- Inability to launch the rocketbar when it's collapsed.
- Random windows appearing when scrolling (may be bug 1097941).

These are all really bad issues and I'm not sure how we're regressing so badly - though it could all stem from a single platform bug.
Flags: needinfo?(anygregor)
(Reporter)

Comment 2

5 years ago
If you switch between landscape and portrait mode I see:
First, the collapsed rocketbar is missing and I see the background instead.
Once I switch a few more times I see the statusbar icons in the middle of the status bar again and its overlapping the URL field.

Trying to upload a video later.
Flags: needinfo?(anygregor)
(In reply to Gregor Wagner [:gwagner] from comment #3)
> For example:
> https://www.youtube.com/watch?v=z7qFCrRKYbM&feature=youtu.be

It says this video is private..
(Reporter)

Comment 5

5 years ago
(In reply to Kevin Grandon :kgrandon (In Europe/Conf until 11/24) from comment #4)
> (In reply to Gregor Wagner [:gwagner] from comment #3)
> > For example:
> > https://www.youtube.com/watch?v=z7qFCrRKYbM&feature=youtu.be
> 
> It says this video is private..

huh? Should be fixed now. I could only reproduce this bug with private mode. Otherwise I would blame it on 1044736 as well.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 2.2+
(Reporter)

Updated

5 years ago
Whiteboard: [systemsfe]
(Reporter)

Updated

5 years ago
Target Milestone: --- → 2.2 S1 (5dec)
So I was finally able to reproduce this, and what's interesting is that sometimes the two times will mis-match which shouldn't be possible to do so. Additionally if you take a screenshot when it hits this, it preserves the notification background over the duplicated statusbar, even though it isn't in the DOM.

It seems to me that we're hitting some invalidation problem in the platform, so I'm going to move to the graphics component. In the meantime I'll see if there's anyway we can workaround this in gaia.
Assignee: kgrandon → nobody
Component: Gaia::System::Window Mgmt → Graphics
Product: Firefox OS → Core
Benoit - any ideas here?
Flags: needinfo?(bgirard)
Is this the expected color? If so it's an under-invalidation bug. Getting a gecko regression window here would be great.
Component: Graphics → Layout
Flags: needinfo?(bgirard)
The expected result is that the entire rocketbar in the screenshot should be purple. What happened in this PR is that a notification came down, then was supposed to disappear. Instead it's remaining on the screen.

I'll see if I can get a gecko regression range, though I'm not sure if we have a known good commit at this time.
I can't reproduce the problem. The patch in bug 1097941 might help but it's hard to know since the trigger for that bug is very specific.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.