Problem with Yahoo Mail in Firefox version 33

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Joerg, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Yahoo!])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8524088 [details]
folder names invisible due to white overlay

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

Problem first occurred after update to Firefox version 33.
I open Y! Mail and see my mail folders on the left side of the window.
Then I place the cursor in the folder area and start scrolling down the folder list using the mouse wheel.



Actual results:

The folder list is temporarily overlayed by a white rectangle and the folder names disappear (attachment).
After moving the mouse a bit the white rectangle disappears and the folder list looks normal again.


Expected results:

Scrolling the folder list shouldn't cause the folder list looking that strange.

Comment 1

4 years ago
If you restart with add-ons disabled (see the help menu), does the issue go away? (this will also turn off graphics hardware acceleration, which is what would make the difference)

Can you try out https://beta.mozilla.org/, and see if it's better with that?

If none of those work, can you go to about:support (Help > Troubleshooting information) and copy-paste the "Graphics" section from there into a comment here?

Thank you!
Component: Untriaged → Untriaged
Flags: needinfo?(jdehmel69)
Product: Firefox → Core
(Reporter)

Comment 2

4 years ago
Starting FF with disabled add-ons fixed the problem. Installing the beta version did it not.

The problem also disappeared after disabling hardware acceleration in FF options / advanced.

Do you see any chance to get the problem fixed but to have hardware acceleration enabled?

As requested find below the grafics settings.

Best regards,
Joerg

Grafik
------
ClearType-Parameter: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
DirectWrite aktiviert: false (6.2.9200.16571)
Geräte-ID: 0x0166
Geräte-ID (GPU #2): 0x0de9
GPU #2 aktiv: false
GPU-beschleunigte Fenster: 0/1 Basic (OMTC)
Karten-Beschreibung: Intel(R) HD Graphics 4000
Karten-Beschreibung (GPU #2): NVIDIA GeForce GT 630M
Karten-RAM: Unknown
Karten-RAM (GPU #2): 2047
Karten-Treiber: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Karten-Treiber (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Treiber-Datum: 3-19-2012
Treiber-Datum (GPU #2): 5-12-2013
Treiber-Version: 8.15.10.2696
Treiber-Version (GPU #2): 9.18.13.2018
Vendor-ID: 0x8086
Vendor-ID (GPU #2): 0x10de
WebGL-Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(jdehmel69)

Comment 3

4 years ago
Jörg: your graphics card driver is relatively old (March 2012); it's possible installing newer drivers might fix the problem. Ideally, we should 'just work' though. You could also give nightly a shot ( https://nightly.mozilla.org) but that's a lot less stable than release (as opposed to beta, with which there is comparatively a lot less difference in stability), so depending on your experience with it you might not want to run it for day-to-day browsing. It'd be interesting to know if the same problem still persists there, though.

Milan, can you place this one in terms of whether we can/should blocklist or whether we can investigate further and/or are aware of this issue already?
Component: Untriaged → Graphics: Layers
Flags: needinfo?(milan)
(Reporter)

Comment 4

4 years ago
After updating the graphics driver the problem is indeed fixed.

Yahoo Mail works correctly again with hardware acceleration enabled in FF.

So for me the issue is solved. 

Do you need some more input from my side?

Thanks for your support,
Joerg
Is the configuration from comment 2 when the problem originally disappeared, without updating the driver?  Or is that the configuration that was showing the problem?
Flags: needinfo?(milan) → needinfo?(jdehmel69)
(Reporter)

Comment 6

3 years ago
Yes, the configuration from comment 2 is the one without updating the driver.
Here I was able to fix the problem in 2 ways:
- add-ons disabled, hw acceleration enabled
- add-ons enabled, hw acceleration disabled
Flags: needinfo?(jdehmel69)

Updated

3 years ago
Flags: needinfo?(milan)
This seems to be an "inverse" problem, based on comment 2 and comment 6.  In the original configuration, looks like we're blacklisting the driver version and we're running with basic OMTC and with SW painting, and we have a problem.  Once the driver is updated, the problem goes away, and presumably we're now using D3D OMTC and D2D painting.

Now that it runs properly, what does about:support (for graphics) look like?  Which version driver, and what values for GPU-beschleunigte Fenster and AzureContentBackend?
Flags: needinfo?(milan)

Updated

2 years ago
platform-rel: --- → ?

Updated

2 years ago
Whiteboard: [platform-rel-Yahoo!]
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.