[Dual SIM] With 2 locked SIMs, cannot enter pin of second SIM unless the first is entered

VERIFIED FIXED in 2.2 S1 (5dec)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rmead, Assigned: mancas)

Tracking

({regression})

unspecified
2.2 S1 (5dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-exploratory-3], )

Attachments

(2 attachments)

Posted file Flame2.2logcat.txt
Description:
When using dual SIMs with SIM Lock enabled on both cards, you cannot enter the pin of SIM 2 until you put in the pin for SIM 1. If you choose Skip on SIM 1 prompt, it skips SIM 2 also.
   
Prereq:
Have 2 SIM cards in the device with SIM Lock enabled on both of them.

Repro Steps:
1) Update a Flame device to BuildID: 20141117040203
2) If SIM PIN prompt hasn't occured, open dialer app
3) Choose to skip the first prompt for SIM 1
  
Actual:
The prompt closes without ever asking for SIM 2
  
Expected: 
The prompt for SIM 2's pin should appear

  
Flame 2.2(319mb)(KitKat)(Shallow Flash)

Device: Flame 2.2 Master
BuildID: 20141117040203
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 21b745197618
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

  
Repro frequency: 100%
See attached: logcat, video - http://youtu.be/_J4HZ1999UE
This issue does NOT occur on Flame 2.0(319mb) and Flame 2.1(319mb)

When a device has Dual SIM cards with SIM lock enabled on both of them, If you choose to skip inputting SIM 1's sim, you won't be prompted to enter SIM 2's pin.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117000200
Gaia: 086a668942292168f312b3bb53e275fa0886fab1
Gecko: a57b299c5cf2
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

This completely blocks the user from entering SIM pin 2, until they enter SIM pin 1. The user should have the option to enable each pin seperatley.

Also this seems to be similar to bug 1059837
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Comment 1 should say that it DOES ask SIM pin for the second SIM on 2.1.
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141106221308
Gaia: 284253475469b58d549fa48aee67dd1fc814dbc9
Gecko: 90d6489edae2
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141106225407
Gaia: 83eaaae5fc609aa414d27a13a0237acb2d647a3a
Gecko: 742640491a42
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 83eaaae5fc609aa414d27a13a0237acb2d647a3a
Gecko: 90d6489edae2

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: 284253475469b58d549fa48aee67dd1fc814dbc9
Gecko: 742640491a42

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/284253475469b58d549fa48aee67dd1fc814dbc9...83eaaae5fc609aa414d27a13a0237acb2d647a3a

Caused by Bug 1062819.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Caused by Bug 1062819 - NI to patch author to investigate.
Blocks: 1062819
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(alive)
QA Contact: pcheng
Assignee: nobody → b.mcb
:mancas are you on this one?
Flags: needinfo?(alive) → needinfo?(b.mcb)
Yes, I'm working on this issue. It seems to be a problem with the comparisons. I think today I will have a first approach of the patch
Flags: needinfo?(b.mcb)
(In reply to Manuel Casas Barrado [:mancas] from comment #7)
> Yes, I'm working on this issue. It seems to be a problem with the
> comparisons. I think today I will have a first approach of the patch

Nice, thank you!
Posted file Proposed patch
Hey Alive, could you take a look at the patch?

Thanks!
Attachment #8527622 - Flags: review?(alive)
Comment on attachment 8527622 [details] [review]
Proposed patch

r=me thanks !
Attachment #8527622 - Flags: review?(alive) → review+
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/d39f9a2cd854268f42e86249655c653af2f1dd65
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)
Verified the issue is fixed on 2.2 Flame

SIM 2 PIN screen opens up after SIM 1 PIN was skipped 

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141208040202
Gaia: 0e429d970c160e580e19e61ad8ff5612de159f00
Gecko: c4c7442e9113
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.