XUL boxes take max-height of children, regardless of !important

VERIFIED INVALID

Status

()

Core
XUL
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Colin Phillips, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
No matter what I try to do, I cannot seem to make a textbox and button be
different heights when inside the same <box>.  Look at the following code:

      <box style="min-height:100px !important;">
         <textbox style="max-height:10px;"/>
         <button label="i am tall" style="min-height:100px;"/>
      </box>

What should be happening is the box should be 100px in height with a 10px high
textbox on the left and a 100px high button on the right.  What I end up getting
is a box that is 10px high with all of it's children also 10px high.
(Assignee)

Comment 1

17 years ago
This is not a bug.  You need to read up on box-align.  hbox doesn't pay any
attention to height values when align is set to stretch (which is the default).
 If you change the value of align, then the height values will be honored.
(Assignee)

Comment 2

17 years ago
marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
:)  You're quite right.  I had actually read that, and I thought I tried that,
but I guess I was doing something very silly.

Anyways, thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.