Context menu of news:// URLs doesn't contain Open Link in New Window/Tab

RESOLVED EXPIRED

Status

SeaMonkey
UI Design
--
minor
RESOLVED EXPIRED
17 years ago
4 years ago

People

(Reporter: Jerome Lacoste, Unassigned)

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

When right clicking on a news link (news://), the 'Open in a new tab' option is
not available. But clicking on the link does open the page in the browser.

Reproducible: Always
Steps to Reproduce:
1. Go on http://www.mozilla.org/hacking/portable-cpp.html#cpp_casts
2. Right click on the link named 'explanation' pointing to
news://news.mozilla.org:119/36718AB4.4134F58C%40netscape.com

Actual Results:  Menu appears do not contain 'Open in new Tab' option

Expected Results:  Menu appears offers 'Open in new Tab' option

Closest bug found:
101955 'Middle-click -> Open in new tab fails for Mail/News URLs'
I've put the bug on All platform, All OS and minor (one can use CTRL-T and copy
the link even if it is not that nice).

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 101955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
I am the reporter, and I would like to point out that in my comments, I
mentionned bug 101955, but didn't think it was a duplicate.
Bug 101955 wants that middle click acts as Open in New Tab from the Mail/News.
This one requires 'Open In New tab' accessible from right click menu, within the
Navigator. This seems to be different.
Can someone confirm these bugs are really duplicates?

Comment 3

17 years ago
Yes, this is no duplicate. Bug 101955 is about clicking a link in a mail, this
is about clicking a link in the browser.

But it is important (imo) that both menu entries: "Open in new Window" and "Open
in new Tab" are missing (So this is probably not a tab-browser issue).
Middle-click to open in a new tab works.

Comment 4

17 years ago
Oops.. I've marked this bug as a dupe because of bug 107557.

But I seem to have been sleeping and have misread your bugreport
(understatement:).. sorry!

Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Updated

16 years ago
Depends on: 114843
(Reporter)

Comment 5

16 years ago
Bug has not been confirmed. I would like it to go open :)

The problem comes from:
[
http://lxr.mozilla.org/seamonkey/source/xpfe/communicator/resources/content/nsContextMenu.js#82
]

where the option 'Open in New Tab' appears only if the link is saveable, but
news links are not saveable (bug 114843).

If bug 114843 isn't to be solved anytime soon, I can provide a hack that would
make us. But I don't think it is the right way to go.

If bug 114843 isn't a real bug, then solving it will probably solve that one
automatically.


No longer depends on: 114843

Updated

16 years ago
Depends on: 114843
why do we require a link to be saveable to "open" it??
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 116085 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
damn, wrong tab, sorry for the stupid comment :(

Comment 10

16 years ago
Reassigning to new component owner.
Assignee: hyatt → jaggernaut

Comment 11

16 years ago
should there be a separate bug opened for the additional 'open in new window'
menu item that is missing, or is one already out there?

Comment 12

16 years ago
-> future
Target Milestone: --- → Future

Updated

16 years ago
QA Contact: blaker → sairuh

Comment 13

16 years ago
This bug cannot be a Tabbed Browser issue since both open in new window and open
in new tab is missing. --> XP apps: GUI features.
Assignee: jaggernaut → blaker
Component: Tabbed Browser → XP Apps: GUI Features
QA Contact: sairuh → paw
Summary: 'Open in new Tab' not available for news:// URL → Context menu of news:// URLs doesn't contain Open Link in New Window/Tab

Comment 14

15 years ago
I have a patch for this.
Assignee: blaker → stefan

Updated

15 years ago
Status: NEW → ASSIGNED

Comment 15

15 years ago
Created attachment 122503 [details] [diff] [review]
Show Open in new Window/Tab menu items for news/snews links

initOpenItems doesn´t use isLinkSaveable anymore. The open menu items are shown
for all protocols except mailto, javascript and irc.

This patch also fixes a small issue with the isLinkSaveable function: irc-links
were saveable, so the "Save Link Target As..." Menu item was falsely shown.

Comment 16

15 years ago
Comment on attachment 122503 [details] [diff] [review]
Show Open in new Window/Tab menu items for news/snews links

timeless made some suggestions on IRC I´ll try to incorporate before requesting
r/sr.
Attachment #122503 - Attachment is obsolete: true

Comment 17

14 years ago
Created attachment 147666 [details]
Test document

Test document with links to test whether the correct context menu items appear.


I think rather than blacklisting some protocols a better approach would be to
whitlist the protocols which can be saved and opened in new windows/tabs. After
some testing I think these are:

http, https, ftp, news, snews, data and gopher.

One problem remains: If MailNews is not installed news and snews are nor
registered protocols and the context menu items don't work in this case. This
method

http://lxr.mozilla.org/mozilla/source/netwerk/base/public/nsIExternalProtocolHandler.idl#49


seems to be exactly what would be needed to solve this problem, but I think it
can't be used from JavaScript. Or?

Updated

14 years ago
Attachment #147666 - Attachment is patch: false
Attachment #147666 - Attachment mime type: text/plain → text/html

Comment 18

14 years ago
(In reply to comment #17)
> One problem remains: If MailNews is not installed news and snews are nor
> registered protocols and the context menu items don't work in this case.

On a second thought this is a marginal problem given that even a left-click on
the link doesn't work in this case. You get an alert "<protocol name> is not a
registered protocol".

(In reply to comment #7)
> why do we require a link to be saveable to "open" it??

It's not a requirement. It just happens to be the case that both classes of
links are nearly identical at the moment, so the onSaveableLink property is
reused. If there are more cases of links that aren't saveable but can be opened
in a new window/tab in the future these could be added to this if-condition:

http://lxr.mozilla.org/seamonkey/source/xpfe/communicator/resources/content/nsContextMenu.js#108

Comment 19

14 years ago
Created attachment 147708 [details] [diff] [review]
Better patch

This patch makes the menu items "Open Link in New Tab", "Open Link in New
Window" and "Save Link Target As..." available to all protocols where these
actions work.

Updated

14 years ago
Attachment #147708 - Flags: review?(timeless)

Comment 20

14 years ago
there's work on an api for this. perhaps you should poke and rely on that instead.

Updated

14 years ago
Attachment #147708 - Flags: review?(timeless)
Product: Core → Mozilla Application Suite
Assignee: Stefan.Borggraefe → nobody
Status: ASSIGNED → NEW
QA Contact: pawyskoczka → guifeatures
Target Milestone: Future → ---

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Comment 22

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 23

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.