Closed Bug 1100681 Opened 8 years ago Closed 8 years ago

[RTSP] Network error when watching streaming video while hotspot enabled then turning off

Categories

(Firefox OS Graveyard :: RTSP, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: jlee, Assigned: ethan)

References

()

Details

(Whiteboard: [2.1-exploratory-3])

Attachments

(1 file)

Description:
There is a network error when user streams video while hotspot is enabled and then turns off hotspot. User must turn off Wi-Fi and then re-enable to continue streaming video.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141117001201
2) Settings > turn on Wi-Fi hotspot
3) Go to Browser > watch youtube video (youtu.be/Wjs3_hY29Q8)
4) Go back to Settings while streaming > turn off hotspot > make sure Wi-Fi starts up again
5) Go back to Browser that is streaming video
6) Observe
  
Actual:
Streaming video does not continue and has network error when watching on hotspot, turning off hotspot, then returning to video. 
  
Expected: 
Streaming video continues when watching while hotspot is enabled and then turning off hotspot. There is not a network error.
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: Turning off Wi-Fi and then turning back on again seems to fix issue.
  
Repro frequency: 100%
See attached: video clip (http://youtu.be/5qzczyi4ohI), logcat (networkerror_logcat.txt)
Flags: needinfo?(dharris)
Issue seen on Flame 2.2 and Flame 2.0.

Streaming video does not continue and has network error when watching on hotspot, turning off hotspot, and then returning to Wi-Fi connection. 

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141117040203
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 21b745197618
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141117000200
Gaia: 086a668942292168f312b3bb53e275fa0886fab1
Gecko: a57b299c5cf2
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
This appears to break Wi-Fi. It does not only affect the youtube clip. Attempting to use Browser/Rocketbar to search internet does not work after following steps above.
[Blocking Requested - why for this release]:

Nominating to block on 2.0 for this. The wifi will show in the status bar, and in the settings app as being connected. However, when the user tries to use something that requires an internet connection, it will behave as if there is no internet connection.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
2.0? is a bit too late, and there is a recovery mechanism mentioned in comment 2.  2.1? is also tight on blockers, so going to move this out to 2.2?  this also seems to be specific to RTSP, so need the RTSP team to chime in.   it's also not a regression.
blocking-b2g: 2.0? → 2.2?
If I saw the repo steps correctly, it's connected to Youtube server not RTSP. So I don't think it's the problem related to RTSP. 
BTW, I can't reproduce the problem on 2.2 following STRs.
ni Jeremiah to confirm Comment 5, it's not reproducible in 2.2 now.
Flags: needinfo?(jlee)
Issue still occurs on Flame 2.2.

Streaming video does not continue and has network error when watching on hotspot, turning off hotspot, then returning to video. Wait 3-5 sec when returning to video.

Note: This appears to break Wi-Fi. It does not only affect the youtube clip. Attempting to use Browser/Rocketbar to search internet does not work after following steps above.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141216040205
Gaia: af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko: a3030140d5df
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(jlee) → needinfo?(hochang)
(In reply to Jeremiah Lee from comment #7)
> Issue still occurs on Flame 2.2.
> 
> Streaming video does not continue and has network error when watching on
> hotspot, turning off hotspot, then returning to video. Wait 3-5 sec when
> returning to video.
> 
> Note: This appears to break Wi-Fi. It does not only affect the youtube clip.
> Attempting to use Browser/Rocketbar to search internet does not work after
> following steps above.
> 
> Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
> BuildID: 20141216040205
> Gaia: af3d2f89f391c92667e04676fc0ac971e6021bb7
> Gecko: a3030140d5df
> Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
> Version: 37.0a1 (2.2 Master)
> Firmware: V188-1
> User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Hi Jeremiah, I still can't reproduce the problem following steps in description above. Where can I get the image you are testing from? Do you use same flash tool from [1]? 

[1] https://github.com/Mozilla-TWQA/B2G-flash-tool
Flags: needinfo?(hochang) → needinfo?(jlee)
Per offline talk with Ethan, he can help to track this bug.
Assignee: nobody → ettseng
I followed the STR in comment 0 using Flame 2.1 and 3.0.
But I cannot reproduce this bug.

After I turned off Wi-Fi hotspot manually, which automatically turns on Wi-Fi connection,
I can resume playing youtube video without seeing any error message.
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Closed: 8 years ago
Flags: needinfo?(jlee)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.