[3rd][ConnectA2] ConnectA2 will exit automatically after unlock screen.

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #777196 +++
 Created an attachment (id=927534)
 ConnectA2 slog
 	
 
  DEFECT DESCRIPTION:
 ConnectA2 will exit automatically after unlock screen.
 
  REPRODUCING PROCEDURES:
  1. Enter "ConnectA2"
  2. Press power key to lock screen
  3. Unlock screen
  4. ConnectA2 exit automatically,MS stay on idle screen --KO
 
  操作步骤:
  1. 填好登录信息,然后点击注册;
  2. 点击电源键,让屏幕锁;
  3. 点击电源键,然后解锁屏幕;
  4. Connect A2 界面自动退出,手机停在待机界面--KO
 
  预期结果:
  解锁后,仍然在ConnectA2界面。
 
  EXPECTED BEHAVIOUR:
  Connect A2 don't exit automatically after unlock screen.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
  100%
 
  For FT PR, Please list reference mobile's behavior:
  暂时没有Soul 3.5 FF对比行为。
 ++++++++++ end of initial bug #777196 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8524373 [details]
ConnectA2 slog
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: 1054172
Flags: needinfo?(fan.luo)
Keywords: qawanted
QA Contact: ckreinbring
The bug repros on Flame 2.2, 2.1, 2.0 and 2.0 base.  All are on engineering builds with shallow flash.
Actual result: When the device goes into lock mode while ConnectA2 is open, ConnectA2 will be closed when the user unlocks the device.

Flame 2.2
BuildID: 20141120053204
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 7d17b594834f
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
BuildID: 20141120063205
Gaia: 66e6a55892d2c5843d32ebbb63795d2d56892613
Gecko: 5afcd7e1b815
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0
BuildID: 20141120090603
Gaia: a64ccebcfae8971388c5271546fc7f2acaa704b7
Gecko: 3530e060bd82
Platform Version: 32.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 Base
BuildID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Gecko: 
Platform Version: 32.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
QA Contact: ckreinbring

Updated

4 years ago
status-b2g-v2.0M: --- → affected
Hi Thomas,
Can you help to inform ConnectA2 developer this issue?.
Thanks!
Flags: needinfo?(telin)
Created attachment 8527527 [details]
Verify.3gp

This bug can be reproed on Woodduck 2.0M and Flame 2.0/2.1/2.2

Found time: 16:21

Woodduck build:
Gaia-Rev        87b23fa81c3b59f2ba24b84f7d686f4160d4e7cb
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141124050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1416776748
FW-Date         Mon Nov 24 05:06:19 CST 2014
------------------
Flame 2.0:
Gaia-Rev        124c2f85f1b956e9e8429dab5121de702a3bc197
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6b59dd2837c1
Build-ID        20141123000206
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.032645
FW-Date         Sun Nov 23 03:27:00 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.1 build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
------------------
FLame2.2 build:
Gaia-Rev        c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c9cfa9b91dea
Build-ID        20141123040209
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.082659
FW-Date         Sun Nov 23 08:27:14 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
@Harald - Does this seem like an app issue? Does the developer have control of what happens to the app when the device screen is locked.

If so, please work with ConnectA2 to resolve. Feel free to NI Michael to help facilitate communication with the developer.
Component: Gaia → Preinstalled B2G Apps
Flags: needinfo?(telin) → needinfo?(hkirschner)
Product: Firefox OS → Tech Evangelism
There are no events fires that would notify an app about the lock screen use. CA2 can't fix anything here. I would expect this is caused by a platform regression.
Flags: needinfo?(hkirschner)
ni? on Naoki who usually had some good luck investigating semi-random crashes.
Component: Preinstalled B2G Apps → Gaia::System::Lockscreen
Flags: needinfo?(nhirata.bugzilla)
Product: Tech Evangelism → Firefox OS
Looking at the logs... I don't think it crashed; I think it got killed:
12-31 19:02:41.170    89   312 I Gecko   : [Parent 89] WARNING: waitpid failed pid:365 errno:10: file /local/build/Fire-C-2G-release/v11C/B2G/gecko/ipc/chromium/src/base/process_util_posix.cc, line 254
12-31 19:02:41.170    89   312 I Gecko   : [Parent 89] WARNING: Failed to deliver SIGKILL to 365!(3).: file /local/build/Fire-C-2G-release/v11C/B2G/gecko/ipc/
I can't reproduce the issue on 3.0, nor in 2.2

Also to note, looking at the video, the video shows that it's an engineering build. Use either the user build or a user debug build, or make sure to go into settings and have adb only selected.  the devtools portion takes up a lot of memory.

Also if the device memory is throttled down, make sure to throttle it down to 319 not 256.

Looking at the log and also the video, it very much seems like a LMK issue not a real crash.

I think Connect2A may want to look into their app memory usage amount and see if they can reduce that down.
Flags: needinfo?(nhirata.bugzilla)

Comment 12

4 years ago
I am also unable to reproduce this issue on a user build of the Flame. Closing this bug, Won't Fix.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.