[Stingray] Capturing wrong screenshot by getScreenshot() at some pages

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nakaoka.hi, Assigned: yifan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Capturing wrong screenshot by getScreenshot() at below pages.
http://www.odn.ne.jp/
http://www.fresheye.com/

Updated

4 years ago
Blocks: 1083063
Evelyn - is this bug in the correct component?
Flags: needinfo?(ehung)
(Assignee)

Comment 2

4 years ago
Is it wrong screenshot size, page layout or an entirely different page? Could you please provide an image of the error?
Flags: needinfo?(nakaoka.hi)

Updated

4 years ago
Component: Gaia::System::Browser Chrome → DOM
Flags: needinfo?(ehung)
Product: Firefox OS → Core

Comment 3

4 years ago
It potentially be a mozbrowser API issue, already change its component. Thanks, Kevin.

Updated

4 years ago
Assignee: nobody → yliao

Comment 4

4 years ago
Hi YiFan, need your help on this one, thanks!
(Reporter)

Comment 5

4 years ago
Created attachment 8529013 [details]
ODN.jpg

image of screenshot of http://www.odn.ne.jp/
Flags: needinfo?(nakaoka.hi)
(Reporter)

Comment 6

4 years ago
Created attachment 8529015 [details]
fresheye.jpg

image of screenshot of http://www.fresheye.com/
(Reporter)

Comment 7

4 years ago
- rendering size of above web page
  1024 x 756 : cannot reproduce
  1256 x 630 : reproduce

- version
  v2.0       : cannot reproduce
  after v2.1 : reproduce

Comment 8

4 years ago
yifan, please update here. Thanks.
Flags: needinfo?(yliao)
(Assignee)

Comment 9

4 years ago
Created attachment 8538388 [details]
test-screenshot.zip

The app for verifying the getScreenshot issue.

Test results by Nakaoka-san:

- URL for reproducing
 http://www.odn.ne.jp/
 http://www.fresheye.com/

- rendering size of above web page and size of getScreenshot()

  rendering size     argument of getScreenshot()
  1024 x 756     ->     480 x 270       : cannot reproduce
  1256 x 630     ->    1256 x 630       : cannot reproduce
  1256 x 630     ->     480 x 270       : reproduce

- version
  v2.0       : cannot reproduce
  v2.1(below version) : reproduce
    Gecko: https://git.mozilla.org/?p=releases/gecko.git;a=commit;h=3b25cb1121b5a528ae7678ec75b52261c477c7ec
    Gaia:  https://git.mozilla.org/?p=releases/gaia.git;a=commit;h=44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
  v2.1(below version) : cannot reproduce
    Gaia:  master of mozilla-central
Flags: needinfo?(yliao)
(Assignee)

Comment 10

4 years ago
Hi Nakaoka-san,

This issue is highly unlikely related to gaia. Wondering if it is possible that the gecko version on your tv is broken.

Is there any specific reason that prevents you from upgrading gecko?
Flags: needinfo?(nakaoka.hi)
(Reporter)

Comment 11

4 years ago
It is difficult to change the gecko version because Mozilla and we decided to use v2.1 and now we are developing gaia on Gecko v2.1.
Flags: needinfo?(nakaoka.hi)
(Assignee)

Comment 12

4 years ago
Hi Nakaoka-san,

Sorry that I didn't make it clearer. What I meant is the latest commit on Gecko v2.1.
(Reporter)

Comment 13

4 years ago
This bug is normal priority, so we will not change Gecko version because there is a higher risk for the product that was already shipped.
On the other hand for the new product, we will update to the latest commit on Gecko v2.1.

Updated

4 years ago
Whiteboard: [ft:conndevices]

Updated

4 years ago
Blocks: 1115611
No longer blocks: 1083063

Comment 14

4 years ago
Hi Nakaoka-san and Daisuke-san, is this problem still exist in the latest build on Stingray? If no, I'd like to close this bug, thanks.
Flags: needinfo?(nakaoka.hi)
Flags: needinfo?(938.daisuke)
(Reporter)

Comment 15

4 years ago
The problem does not exist in the Latest build on Stingray. No problem, it's OK to close the bug.
Flags: needinfo?(nakaoka.hi)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(938.daisuke)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.