Closed Bug 1100856 Opened 10 years ago Closed 6 years ago

[Flame][Dialer]A prompt "unable to make a phone call now" appeared after you call out a blank number.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:3.0?, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
feature-b2g 3.0?
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: huayu.li, Unassigned)

References

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(4 files)

Attached video 2.mp4
[1.Description]:
[Flame][v2.1&2.2][Dialer]A prompt "unable to make a phone call now" appeared after  you call out a blank number.
Occurence time:14:03
see attachments:log1.txt,2.mp4.
[2.Testing Steps]: 
1.Launch dial.
2.Call out a blank number(ex:1555668886).
3.Waiting for the call end automatically.

[3.Expected Result]: 
3.Call page should be displayed.

[4.Actual Result]: 
3.A prompt   "unable to make a phone call now" appeared.

[5.Reproduction build]: 
FLame 2.1 new build:
Gaia-Rev        81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3572aa3e6766
Build-ID        20141117001201
Version         34.0

FLame 2.2 new build:
Gaia-Rev        ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2d0a51ef828d
Build-ID        20141117160200
Version         36.0a1

[6.Reproduction Frequency]: 
Always Recurrence,3/3
Attached file logcat1.txt
I can repro this on 2.1 and 2.2 with a French SIM card. Like said in step 3, you must wait until the carrier ends the call.
Hi Eric,could you help to check this issue.
Flags: needinfo?(echang)
QA Whiteboard: [COM=Gaia::Dialer]
Flags: needinfo?(echang)
I can't repro this bug on latest Woodduck v2.0 and Flame v2.0&2.1&2.2&3.0.
If anyone can repro it, please reopen again.

Woodduck 2.0 build:
Build ID               20150217050313
Gaia Revision          a1b5959728c8bc2a82354e197bb161922d419866
Gaia Date              2015-02-13 09:00:02
Gecko Revision         08bfa30001d6ba618466a97e65adcd481a19c292
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1424120751
Firmware Date          Tue Feb 17 05:06:15 CST 2015

Flame 2.0 build:
Build ID               20150216000225
Gaia Revision          ecb1bbc3b9c00f82df172427f65d6f67e34ed533
Gaia Date              2015-02-11 20:40:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/3051696eafcc
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.033354
Firmware Date          Mon Feb 16 03:34:05 EST 2015
Bootloader             L1TC000118D0

Flame 2.1 build:
Build ID               20150216001203
Gaia Revision          e8eba437af02820f74d122aec83b6001df6f89e3
Gaia Date              2015-02-13 05:26:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9d04f9149ca4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.035307
Firmware Date          Mon Feb 16 03:53:18 EST 2015
Bootloader             L1TC000118D0

FLame 2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

FLame 3.0 build:
Build ID               20150216010344
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.050451
Firmware Date          Mon Feb 16 05:05:02 EST 2015
Bootloader             L1TC000118D0
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Please ignore Comment 4,sync with reporter, this bug still exists on lasted Flame v2.0&2.1&2.2&3.0.

Update log: logcat_v2.2_1506.txt
Reproduce rate: 5/5

Device: Flame 2.0 (Affected)
Build ID               20150324000203
Gaia Revision          896803174633fc6acd3fd105f81c349b8e9b9633
Gaia Date              2015-03-10 06:32:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e5a746852904
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.032045
Firmware Date          Tue Mar 24 03:20:56 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 (Affected)
Build ID               20150324001203
Gaia Revision          b8ae0df34362420fe4a9c90effa5247a1f5c844d
Gaia Date              2015-03-23 23:20:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/36729fd38d2d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041014
Firmware Date          Tue Mar 24 04:10:25 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 (Affected)
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041652
Firmware Date          Tue Mar 24 04:17:03 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (Affected)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This issue has been verified failed on Nexus5 2.2 &3.0.
Reproduce rate: 5/5

Device:N5 2.2[Affected]
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150324.041308
Firmware Date          Tue Mar 24 04:13:23 EDT 2015
Bootloader             HHZ12d

Device:Nexus5 3.0[Affected]
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150324.193526
Firmware Date          Tue Mar 24 19:35:42 EDT 2015
Bootloader             HHZ12d
Whiteboard: [2.2-nexus-5-l]
Attached video v2.2.mp4
Hi Eric,

    When calling out a valid number instead of the blank number in step 2 of Comment 0,  this bug also can be reproduced on latest build of Woodduck 2.0, Flame v2.0 & 2.1 & 2.2 & 3.0 and Nexus 5 v2.2 & v3.0.

Could you help with this bug ?  

Thank you very much!

----------------------------------------------------------------------------
Results:
A prompt "unable to make a phone call now" appears after you call a valid number(eg: 15680013662).

See attachment: v2.2.mp4 & logcat1521.txt
Reproduce rate: 8/10

Device: Woodduck 2.0(Affected)
Build ID               20150529050314
Gaia Revision          f1e51289f830a759c433c238521dd65eedbee157
Gaia Date              2015-05-27 19:33:31
Gecko Revision         6e1bada60fa18f3dd552db7618582879964747d7
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1432847091
Firmware Date          Fri May 29 05:05:12 CST 2015

Device: Flame v2.0(Affected)
Build ID               20150528160203
Gaia Revision          5552bf529d3d6775a968942e9afa6c1d4037362c
Gaia Date              2015-05-21 14:42:19
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/d295e80c5cdd
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.193025
Firmware Date          Thu May 28 19:30:37 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v2.1(Affected)
Build ID               20150528010203
Gaia Revision          05380df3158fa39e1dde1687c0bf11a71f8c6868
Gaia Date              2015-05-27 06:27:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/baa9c64fea6f
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.044033
Firmware Date          Thu May 28 04:40:44 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v2.2(Affected)
Build ID               20150528162502
Gaia Revision          a57ec5786c9f941c690266bbb26049dbb8482b05
Gaia Date              2015-05-28 18:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7012f97f7814
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.201241
Firmware Date          Thu May 28 20:12:53 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v3.0(Affected)
Build ID               20150528160205
Gaia Revision          e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gaia Date              2015-05-28 10:47:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f986e55c4e0b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.192335
Firmware Date          Thu May 28 19:23:44 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2(Affected)
Build ID               20150528162502
Gaia Revision          a57ec5786c9f941c690266bbb26049dbb8482b05
Gaia Date              2015-05-28 18:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7012f97f7814
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150528.202725
Firmware Date          Thu May 28 20:27:45 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 v3.0(Affected)
Build ID               20150528160205
Gaia Revision          e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gaia Date              2015-05-28 10:47:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f986e55c4e0b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150528.191717
Firmware Date          Thu May 28 19:17:35 EDT 2015
Bootloader             HHZ12f
Flags: needinfo?(echang)
QA Whiteboard: [COM=Gaia::Dialer] → [COM=Gaia::Dialer][MGSEI-Triage+]
See Also: → 1042484
This issue could be carrier-dependent, i.e. depending on the call failure cause a carrier sends back. 

However, I still believe the root cause is the way Dialer app deals with the call error messages and the request reject reasons. Please see my suggestion to get the issue fixed properly: bug 1042484 comment 31

Thanks.
AFAIK the blocking gecko work is done, so I am nominating feature-b2g:3.0? to get more attention to fix this confusing UI.
feature-b2g: --- → 3.0?
Flags: needinfo?(echang)
See Also: → 1181779
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 9 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: