firefox/desktop landing page animation broken on Firefox [OSX only]

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: agibson, Assigned: agibson)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1582452], URL)

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
The SVG/CSS intro animation on the firefox/desktop landing page is currently broken in Firefox 35 and above for Mac OSX only, due to a core graphics bug.

I have filed Bug 1083079 (which is being worked on) and helped to narrow down the cause of the regression. However it looks like the the issue won't be fixed until at least Firefox 36, so in the interim it might be best to disable the animation for OSX users on Firefox >= 35.
(Assignee)

Updated

4 years ago
Whiteboard: [kb=1582452]
(Assignee)

Updated

4 years ago
Depends on: 1083079
(Assignee)

Updated

4 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Created attachment 8524511 [details] [review]
GitHub pull request

Pull request to temporarily disable the animation for OSX users on Firefox 35 or greater.

Comment 2

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/97203671ddccec433aa9432276252848c302cc69
[bug 1100861] Temporarily disable firefox desktop intro anim on Firefox 35 OSX

https://github.com/mozilla/bedrock/commit/971369ba9c303a00aef77ec72ee79350194f7b36
Merge pull request #2513 from alexgibson/disable-desktop-anim-fx-mac

[bug 1100861] Temporarily disable firefox desktop intro anim on Firefox 35 (OSX)
Closing as per Comment 2.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.