If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame][Dialer]The voice is very small while tapping dial keyboard.

RESOLVED DUPLICATE of bug 1116040

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1116040
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8524470 [details]
1.mp4

[1.Description]:
[Flame][v2.1][Dialer]The voice is very small while tapping dial keyboard.
occurence time:10:46
see attachments:1.mp4,logcat.txt

[2.Testing Steps]: 
1.Make sure the media voice is 100%.
2.Launch dial.
3.Tap the dial keyboard to input number,check the voice.
4.If the voice is normal,call out the number you input.
5.End call.
6.Tap the dial keyboard agian and check the voice.

[3.Expected Result]: 
6.The voice should be 100%.

[4.Actual Result]: 
6.The voice is very small.

[5.Reproduction build]: 
FLame 2.1 new build:
Gaia-Rev        81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3572aa3e6766
Build-ID        20141117001201
Version         34.0

[6.Reproduction Frequency]:  
occasionally Recurrence,3/5
(Reporter)

Comment 1

3 years ago
Created attachment 8524476 [details]
logcat.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → affected

Comment 2

3 years ago
This issue dose not exist in Flame 2.2
Gaia-Rev        322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67872ce17918
Build-ID        20141230010205
Version         37.0a1
Comment hidden (obsolete)
Wait, this bug was filed before bug 834530 lands (bug 834530 comment 120) on 2.1. QA wanted to check 2.1 again.
Flags: needinfo?(gsvelto)
Keywords: qawanted
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> Wait, this bug was filed before bug 834530 lands (bug 834530 comment 120) on
> 2.1. QA wanted to check 2.1 again.

This bug (comment 0) never talked about going to the emergency call screen. Disregarding STR for bug 834530, I'm unable to reproduce this bug on the reported build. DTMF tone remains unchanged after a call. Bug repro rate: 0/10.

Tested on (reported build):
Device: Flame 2.1 (shallow/full flash, 319MB mem)
BuildID: 20141117001201
Gaia: 81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko: 3572aa3e6766
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

On the side note, this looks like bug 1065147 which had been fixed before this bug was filed.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to Pi Wei Cheng [:piwei] from comment #5)
> This bug (comment 0) never talked about going to the emergency call screen.

You're right. The fix in bug 834530 changed the way the audio channels are used in both dialers, though. That's why I suspected the issue to be fixed since.

Alissa, can you reproduce this issue on a recent build? If not, can you resolve this bug as works for me?
Flags: needinfo?(huayu.li)
(Reporter)

Comment 7

3 years ago
Hi Johan,This issue has been failed verified on Flame 2.1,please refer to new video,after end call 10 second later,the volume recover normal.so we should do step 6 in 10 seconds after step5,could you help to try agian?
Flags: needinfo?(huayu.li) → needinfo?(jlorenzo)
(Reporter)

Comment 8

3 years ago
Created attachment 8544927 [details]
verify1.3gp
Bug 1116040 is a dupe then. I'll mark this one a the duplicate because we have more information in bug 1116040. 

Thanks for checking again, Alissa.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jlorenzo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1116040
You need to log in before you can comment on or make changes to this bug.