add indicator for image manager state to Media tab

RESOLVED DUPLICATE of bug 110075

Status

SeaMonkey
Page Info
--
enhancement
RESOLVED DUPLICATE of bug 110075
17 years ago
9 years ago

People

(Reporter: Quinn Yost (mythdraug), Assigned: db48x)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Image info should contain some indication of an image's
status within the Image Manager.  I'm thinking red x for
site is blocked, green check for permitted, grey ? for
ask.
->daniel and confirming rfe.
Assignee: blakeross → db48x
Summary: [RFE] add indicator for image manager state to View -> Page Info -> Images → [RFE] add indicator for image manager state to View -> Page Info -> Images
(Assignee)

Updated

17 years ago
Blocks: 82059
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
I think what I'll do is set this column up, then make it so that clicking on
this column toggles the state for the image, kind like you can do in mail for
some of the flags in the outliner there. 

However, I'm not sure what the grey question mark icon would represent, perhaps
that the state hasn't been queried yet or something?
Blocks: 110075
No longer blocks: 82059

Comment 3

17 years ago
Plat, OS: --> All
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 4

17 years ago
Sorry for the confusion on the question mark.
I was seeing it representing an image site that
did not exist in cookperm.txt (ie the user
accepted or denied the image but did not ask
mozilla to remember the choice). 
mass moving open bugs pertaining to page info to pmac@netscape.com as qa contact.

to find all bugspam pertaining to this, set your search string to
"BigBlueDestinyIsHere".
QA Contact: sairuh → pmac

Updated

17 years ago
Component: XP Apps: GUI Features → Page Info
(Assignee)

Updated

16 years ago
Blocks: 143951

Updated

16 years ago
Summary: [RFE] add indicator for image manager state to View -> Page Info -> Images → [RFE] add indicator for image manager state to Page Info | Media

Updated

16 years ago
Summary: [RFE] add indicator for image manager state to Page Info | Media → add indicator for image manager state to Page Info | Media

Updated

16 years ago
Summary: add indicator for image manager state to Page Info | Media → add indicator for image manager state to Media tab

Comment 6

16 years ago
Created attachment 104331 [details] [diff] [review]
Very alpha patch; please submit your comments!

What would you say about this?
("Status:" field should appear right below the URL on the Media tab, which says
"Blocked" if the image is blocked).

HOWEVER: I wanted to also add "Not Found" if the image is not found. Does
anybody know what flag/condition/etc should be checked to do so?
(Assignee)

Comment 7

16 years ago
Comment on attachment 104331 [details] [diff] [review]
Very alpha patch; please submit your comments!

Good start. I think however that instead of adding a row to the preview area,
we need a new column in the tree area.

Basically, to add a column you need to add it to the xul file, then add the id
to the list at the top of pageinfo.js, where imageView is declared. Then in
grabAll() you can check the status and add the information to the tree. You'll
probably need to add a way to specify an image in the addRow() function, though
it might be easier to just put an empty string there, and then have it call
setCellImage() [which would need ot be defined of course] seperatly.

>+  <!-- We need cookieOverlay.js because it contains IMAGEPERMISSION constant. --> 
>+  <script type="application/x-javascript" src="chrome://cookie/content/cookieOverlay.js"/>

it would probably be better to just copy the constant.

Comment 8

16 years ago
The general idea for adding a row was to have a flag having "OK / Blocked /
Broken / Not found at given URL" states. And I don't think it'll be a problem to
add such a column to the table too. I will work on it; this was a quick patch I
fixed in a few minutes.

>+  <!-- We need cookieOverlay.js because it contains IMAGEPERMISSION constant. 
>it would probably be better to just copy the constant.

And what if somebody changes that constant in cookieOverlay.js and forgets to
change it here? Then we'll get yet another misterious bug.


P.S. Anybody can give me an advice on how to figure out if the image is a)
broken and b) not found at given URL?
Product: Browser → Seamonkey
QA Contact: pmac

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 110075

Updated

9 years ago
No longer blocks: 110075
(Reporter)

Comment 10

9 years ago
Wow Philip.     Don't you think this would have been marked as a Dupe of my own bug at some other time in the last 7 years?
You need to log in before you can comment on or make changes to this bug.