Average rate sometime exceeds 5 and is 9

RESOLVED FIXED

Status

Marketplace
Statistics
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Flaburgan, Assigned: robhudson)

Tracking

2014-Q4
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8524673 [details]
Capture du 2014-11-18 17:26:23.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141118004001

Steps to reproduce:

I went on https://marketplace.firefox.com/statistics/app/diaspora/average_rating/?start=2014-10-18&end=2014-11-17&interval=day


Actual results:

The rates displayed are sometime equal to 9 when the user only can rate from 1 to 5. See attached file.


Expected results:

Be limited to 5?
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Developer Pages → Statistics
Ever confirmed: true

Updated

3 years ago
Assignee: nobody → robhudson.mozbugs
Priority: -- → P3

Updated

3 years ago
Priority: P3 → P2
(Assignee)

Comment 1

3 years ago
I see that the average was indexed twice for this app/date for some reason. A re-index should fix it.
(Assignee)

Comment 2

3 years ago
A reindex fixed the issue. Thanks for the report.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

3 years ago
Thanks for fixing this, but any idea why it was indexed twice? Maybe this bug should be closed only when we will have understood why the bug appeared?

Especially, this was only a symptom, but the weekly[1] and monhtly[2] charts also have weird data. Looks like the note are sum.

[1]https://marketplace.firefox.com/statistics/app/diaspora/average_rating/?start=2014-10-26&end=2014-11-25&interval=week
[2]https://marketplace.firefox.com/statistics/app/diaspora/average_rating/?start=2014-10-26&end=2014-11-25&interval=month
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

3 years ago
(In reply to Flaburgan from comment #3)
> Thanks for fixing this, but any idea why it was indexed twice? Maybe this
> bug should be closed only when we will have understood why the bug appeared?

This is the first time it happened. If it happens again we can spend the time to look into the cause.
 
> Especially, this was only a symptom, but the weekly[1] and monhtly[2] charts
> also have weird data. Looks like the note are sum.
> 
> [1]https://marketplace.firefox.com/statistics/app/diaspora/average_rating/
> ?start=2014-10-26&end=2014-11-25&interval=week
> [2]https://marketplace.firefox.com/statistics/app/diaspora/average_rating/
> ?start=2014-10-26&end=2014-11-25&interval=month

I'd consider these new bugs -- nothing wrong with the data but how we are querying it. I filed bug 1105338 to fix this issue. Thanks for the report, the weekly/monthly options were added recently.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.