Bug 1101113 (system-dialog-rtl)

[RTL] System Dialogs

RESOLVED FIXED in 2.2 S2 (19dec)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: swilkes, Assigned: gmarty)

Tracking

unspecified
2.2 S2 (19dec)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected)

Details

(Whiteboard: [rtl-meta][systemsfe])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
etienne
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
This is the meta bug for Arabic language support in Sys FE System Dialogs. The release target for full Gaia (all apps) Arabic support is 2.2. 

Per usual, strings for translation will be filed in the L10N component and noted as blocking this bug.

The bidi UX pattern (OS wide) is here:
https://mozilla.app.box.com/s/0y1amh4rwpp6brcxd1hk
(Reporter)

Updated

4 years ago
Blocks: 1064539
No longer blocks: 906270
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → gmarty
(Assignee)

Comment 1

4 years ago
Created attachment 8531705 [details] [review]
Github PR

This patch fixes RTL for system dialogs.
Etienne, can you have a look?
Attachment #8531705 - Flags: review?(etienne)
Comment on attachment 8531705 [details] [review]
Github PR

Looking good, I think we should attach some screenshots and have them UI-reviewed though.
(but maybe another process has already been agreed upon)
Attachment #8531705 - Flags: review?(etienne) → review+
(Assignee)

Comment 3

4 years ago
Landed in master: https://github.com/mozilla-b2g/gaia/commit/1802d44011589ff7194252ec987ec159086cf42a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Adding whiteboard tag [rtl-impact]
Whiteboard: [systemsfe] → [rtl-impact]
Whiteboard: [rtl-impact] → [rtl-meta]
Whiteboard: [rtl-meta] → [rtl-meta][systemsfe]

Updated

4 years ago
Keywords: verifyme

Comment 5

4 years ago
Hi Eric,
   This issue has been verified failed on Flame 2.2.
Reproduce rate:5/5
   We have file a new bug for this situation, see bug 1126209.Hope this can help you.Thanks.
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: --- → affected
Flags: needinfo?(echang)

Updated

4 years ago
See Also: → bug 1126209
Adding depends on 1126209
Depends on: 1126209
Flags: needinfo?(echang)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Peter, I don't think reopening this bug is the right action since it has a patch that landed 2 months ago. Which also kind of makes it not a meta bug. 

I'm going to re-resolve this one. Let's proceed with the new bug 1126209 and I'll move that bug's dependency to system-rtl instead of this one.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
No longer depends on: 1126209
No longer depends on: 1129520
See Also: → bug 1129520
Summary: [META] [RTL] System Dialogs → [RTL] System Dialogs
Target Milestone: --- → 2.2 S2 (19dec)

Comment 8

4 years ago
Clear "verifyme" in keywords.
Keywords: verifyme
Depends on: 1154209

Updated

4 years ago
Depends on: 1154647
You need to log in before you can comment on or make changes to this bug.