linux browser doesn't start since compiled with gcc3

VERIFIED INVALID

Status

--
critical
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: jens-uwe, Assigned: netscape)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010726
Netscape6/6.1
BuildID:    2001111321

since the linux trunk builds are done using gcc3, they doesn't start here
anymore, because a lib is missing. 
I am using Suse7.2, which by default comes with gcc2.95.3

Reproducible: Always
Steps to Reproduce:
1. just start a precompiled nightly build from mozilla.org at a Suse7.2 system
(or many other Linux systems I guess).

Actual Results:  I get the following message:
./mozilla-bin: error while loading shared libraries: libgcc_s.so.1: cannot load
shared object file: No such file or directory

Expected Results:  Mozilla should just start


I guess this bug is connected to the problems mentioned in bug 53486 and bug 79681.
Marking critical, since it prevents me and probably others from using mozilla.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
And so it begins.  To clarify, the gcc30 builds are *test* builds for bug 53486.
 They have not replaced the default egcs builds yet so this is hardly critical.

Since you mentioned bug 53486, you are aware of the fact that libgcc_s.so.1 &
libstdc++.so.3 are system libraries (read: external dependencies). You need to
contact your vendor to get the latest suse packages for them.  Or use your
choice of search engine (rpmfind, freshmeat, google) to find existing packages.  

Comment 2

17 years ago
verified invalid.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.