Have the ability to set reviewer without visiting the site

RESOLVED DUPLICATE of bug 1142251

Status

defect
RESOLVED DUPLICATE of bug 1142251
5 years ago
4 years ago

People

(Reporter: automatedtester, Unassigned)

Tracking

Details

We should either have a flag like bzexport that allows you to set reviewer or reviewboard so look for r=<name> and set the reviewer to <name>
I'd be more inclined to implement parsing r? or r= syntax from the commit message or implementing auto reviewer selecting from changed content before adding adding a command line argument. We have bugs for at least one of those already.

I fear that once you add a command line argument, people get used to it and it becomes difficult to take away. Perhaps we end up having to build it in eventually. I'm not sure yet.
Actually i think all review peers should be pinged when we have a patch for review

e.g.

/testing # ted, ctalbert (I am guessing at who might be here
/testing/marionette # Me, mdas, jgriffin should be pinged
/testing/mozbase # Ahal, wlach (I am sure there are others) should be pinged

If the patch isnt reviewed in X time then all of them should be pinged again.

This would be my ideal
Summary: Have the ability to set reviewer from command line → Have the ability to set reviewer without visiting the site
Using r? is bug 1142251; duping to that.  We will also be able to use in-tree metadata.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1142251
Product: Developer Services → MozReview
You need to log in before you can comment on or make changes to this bug.