Closed Bug 1101205 Opened 8 years ago Closed 8 years ago

[e10s] history doesn't work with Whimsy add-on

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: keeler, Unassigned)

References

(Blocks 1 open bug)

Details

I'm dogfooding e10s, and no pages I'm visiting are being added to my history. Both the history sidebar and the "Show All History" window show nothing for sites I've visited today. Also, visited links aren't turning purple (I'm assuming since no new history is being created).
does this reproduce if you disable all add-ons?
Ah - it appears the problem is with Whimsy (or, at least, history works as expected with it disabled). Sorry, that hadn't even occurred to me.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
lets ensure bwinton knows about this bug, it would be good to figure out what of whimsy causes history to malfunction and eventually have a bug about it if it's a bug in Firefox.
Flags: needinfo?(bwinton)
Summary: [e10s] history doesn't work → [e10s] history doesn't work with Whimsy add-on
That's really weird.  I've got a github issue for it at https://github.com/bwinton/whimsy/issues/100 if anyone wants to follow along there.  (Now to try and find the time to debug it!  :)

If it ends up being a bug in Firefox, shall I put the details here and re-open it, or would you rather a new bug?
Flags: needinfo?(bwinton) → needinfo?(mak77)
(In reply to Blake Winton (:bwinton) from comment #5)
> That's really weird.  I've got a github issue for it at
> https://github.com/bwinton/whimsy/issues/100 if anyone wants to follow along
> there.  (Now to try and find the time to debug it!  :)
> 
> If it ends up being a bug in Firefox, shall I put the details here and
> re-open it, or would you rather a new bug?

I think reopening this would be fine in this case, since we are basically passing the ball each other :)
Flags: needinfo?(mak77)
You need to log in before you can comment on or make changes to this bug.