Visiting www.mozilla.org/firefox/new/ (and others) with an es browser leads to /es-AR/ page.

VERIFIED FIXED

Status

www.mozilla.org
Bedrock
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: cmore, Assigned: kohei)

Tracking

(Blocks: 1 bug)

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1583654] [fxgrowth], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Mike Connor alerted us to a possible bug that we need to dig in to.

He was using Chrome with his accept_lang as:

es,en-GB;q=0.8,en;q=0.6,en-US;q=0.4

When he visited https://www.mozilla.org/firefox/new/

He was presented with https://www.mozilla.org/es-AR/firefox/new/.

The expected result should be https://www.mozilla.org/es-ES/firefox/new/.

I also checked Google Analytics and if I look at people who visit /es-AR/firefox/new/, 50% of them are running the "es" language. 

I am able to replicate this bug, but only on /firefox/new/.

If I set my Chrome browser to "spanish - espanol" and visit:

https://www.mozilla.org/ it redirects to https://www.mozilla.org/es-ES/ as expected.

If I visit https://www.mozilla.org/firefox/new/ it redirects to https://www.mozilla.org/es-AR/firefox/new/

Why is the locale detection on www.mozilla.org homepage correctly giving the user es-ES content, but the /firefox/new/, /firefox/partners/, /firefox/desktop/, giving es-AR for the "es" language? It seems that the homepage is the only page correctly giving es-ES when the accept_lang is "es".
(Reporter)

Updated

4 years ago
Whiteboard: [fxgrowth]
(Reporter)

Comment 1

4 years ago
I have also confirmed that setting Firefox as "es" also presents es-AR to all non-homepage requests.
(Assignee)

Comment 2

4 years ago
Created attachment 8525073 [details] [review]
pull request for funfactory

The same applies to "en" that should be redirected to "en-US" instead of "en-GB". This PR solve both cases.
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Whiteboard: [fxgrowth] → [kb=1583654] [fxgrowth]
(Assignee)

Updated

4 years ago
Component: L10N → Bedrock
Part of this was definitely covered in bug 774675
https://github.com/mozilla/bedrock/blob/master/etc/httpd/global.conf#L10-L12

But I confirm the issue with 'es'->'es-AR' on all pages but the home.
Given the global.conf bit, do we need to adjust behaviour of pt?
(Assignee)

Comment 5

4 years ago
I'll map pt to pt-BR.
(Reporter)

Comment 6

4 years ago
Would we consider mapping/redirecting es-419 to es-ES? es-419 is a growing language and we don't have that currently mapped to anything. It is supposed to represent Latin America and the Caribbean languages and es-ES is probably the most generic. Any other suggestions on what to do with es-419?
The current PR from Kohei will redirect any es-* that we don't explicitly support to es-ES. So until we have something else that we'd like to do with es-419, at least they'll get the default.

es-419 seems odd to begin with since my understanding is that there is a fairly wide difference between many LATAM Spanish dialects. So having a single locale for them all sounds troublesome at best. Though redirecting a specifically LATAM locale to Spain-Spanish also seems odd.

/me shrugs
(Assignee)

Updated

4 years ago
Attachment #8525073 - Attachment description: pull request → pull request for funfactory
(Assignee)

Comment 8

4 years ago
Created attachment 8525441 [details] [review]
pull request for bedrock

Yes, I have just tested my PR locally with Accept-Language: es-419, and /firefox/new/ redirected me to /es-ES/firefox/new/.
(Reporter)

Comment 9

4 years ago
(In reply to Paul McLanahan [:pmac] from comment #7)
> The current PR from Kohei will redirect any es-* that we don't explicitly
> support to es-ES. So until we have something else that we'd like to do with
> es-419, at least they'll get the default.
> 
> es-419 seems odd to begin with since my understanding is that there is a
> fairly wide difference between many LATAM Spanish dialects. So having a
> single locale for them all sounds troublesome at best. Though redirecting a
> specifically LATAM locale to Spain-Spanish also seems odd.
> 
> /me shrugs

Yeah, es-419 is more of a location than a specific language and we really don't have location pages on mozilla.org. Let me check to see what language most es-419 people download. Hang on.
(Reporter)

Comment 10

4 years ago
For es-419 visitor downloads, 43% download es-ES, 24% es-MX, 14% es-AR, 5% es-CL.

As for es-419 visitor countries, 25% is Mexico, 15% is Ecuador, 13% Argentina, 11% Columbia.

You could argue that es-419 should default to es-MX with these numbers, but still it is not 100% ideal for everyone.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 984034
(Assignee)

Updated

4 years ago
Blocks: 879544

Comment 12

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/c824cb26bca9aa69ed26ba87844ce416ac556140
Fix Bug 1101261 - Visiting www.mozilla.org/firefox/new/ (and others) with an es browser leads to /es-AR/ page.

https://github.com/mozilla/bedrock/commit/d1403eac5ba5df9d6e63018f9d0a85ee46c149b5
Merge pull request #2520 from kyoshino/bug-1101261-es-locale

Fix Bug 1101261 - Visiting www.mozilla.org/firefox/new/ (and others) with an es browser leads to /es-AR/ page.

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Verified FIXED on http://www-dev.allizom.org/firefox/new with [es] as my 1st locale/language -- I get redirected to https://www-dev.allizom.org/es-ES/firefox/new/
And Verified FIXED on prod, too.
Status: RESOLVED → VERIFIED
Created attachment 8527087 [details]
Screen Shot 2014-11-21 at 4.21.13 PM.png
:stephend, does that trans bar behavior indicate a bug? Looks like it's asking if you want to view in English when you had your browser set to "es".
Flags: needinfo?(stephen.donner)
(In reply to Paul McLanahan [:pmac] from comment #16)
> :stephend, does that trans bar behavior indicate a bug? Looks like it's
> asking if you want to view in English when you had your browser set to "es".

Could be; I also had "en-US" and "en" in my "Languages"/accept-language header -- I'll confirm with Felipe from the Firefox Desktop team.
(In reply to Stephen Donner [:stephend] from comment #17)
> (In reply to Paul McLanahan [:pmac] from comment #16)
> > :stephend, does that trans bar behavior indicate a bug? Looks like it's
> > asking if you want to view in English when you had your browser set to "es".
> 
> Could be; I also had "en-US" and "en" in my "Languages"/accept-language
> header -- I'll confirm with Felipe from the Firefox Desktop team.

Sorry, Felipe -- I meant to ping you on IRC, but keep forgetting; mind weighing in, here?  Thanks!
Flags: needinfo?(stephen.donner) → needinfo?(felipc)
Hey Stephen, that bar on the screenshot is not part of the front-end translation feature. That bar is in the webpage, which offers to change the language by itself.

So while it's likely a bug, it's part of the website code, which I don't know much about
Flags: needinfo?(felipc)
You need to log in before you can comment on or make changes to this bug.