Closed Bug 1101294 Opened 7 years ago Closed 7 years ago

[OTA] User is unable to install updates after checking for updates while an update downloads

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1093827
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: smiko, Unassigned)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(1 file)

Attached file OTA.txt
Description: If the user checks for updates while downloading an update, the update cannot be installed.

Repro Steps:
1: Update a Flame to 20141117040203.
2: Turn on Wifi 
3: Download the update via the notification center. 
4: While the update downloads, open Settings > Device information > Check Now. (An error message displays "There was an error when cheking for updates."
5: Observe the notification center. 

Actual: Once the update uncompresses, the notification to download the update appears again. Downloading the update again results in a temporary black screen followed by the same behavior.

Expected:The user is able to download the update. 

Device: Flame 2.2
BuildID: 20141117040203
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 21b745197618 
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Notes:
1: The user must perform a factory reset in order to take the update.
2: Cancelling the update and re-downloading results in the same behavior.

Repro frequency: 5/5

See attached: logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: smoketest
Whiteboard: [2.2-Daily-Testing]
You're running out of space, this is a dupe of 1093827
Status: NEW → RESOLVED
Closed: 7 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: smoketest
Resolution: --- → DUPLICATE
Duplicate of bug: 1093827
You need to log in before you can comment on or make changes to this bug.