If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

try running android x86 emulator tests on aws

RESOLVED WONTFIX

Status

Release Engineering
Platform Support
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: kmoir, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/4186] )

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
In the interest of running more tests in the cloud, we should try to run Android x86 on AWS instances.  Notes from Armen re why they run on ix

---

The only note that I find is that we were having some issues about OpenGL:
https://bugzilla.mozilla.org/show_bug.cgi?id=895186#c3

Beyond that I don't know more. Maybe gbrown or ctalbert know.

In any case it might be good to disable S1, S2 & S3 until x86 becomes and
official tier-1 product.
(Assignee)

Updated

3 years ago
Assignee: nobody → kmoir
(Assignee)

Updated

3 years ago
Depends on: 1103097
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/4186]
(Assignee)

Comment 1

3 years ago
Created attachment 8527837 [details]
emulator.log

Failed running opengl tests, upgraded instance to c3.xlarge and trying that now.
(Assignee)

Comment 2

3 years ago
No, same issue on c3.xlarge. So closing for now, perhaps will revisit later on and investigate root cause.  Right now it can continue to run on ix.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

3 years ago
It would be good to split out the tests to so we could run ones that can run on AWS there and run the remaining ones on ix
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Another thing to watch out for is performance. We get fantastic performance on ix with kvm -- see bug 928463.
(Assignee)

Comment 5

3 years ago
Right, I can see that the qemu-kvm packages are not installed on the aws instances but they are on the ix machines.  (I misinterpreted the earlier error message when running the scripts and now see that the missing kvm packages are a problem).  In any case, I was doing some reading today and it seems that kvm doensn't run on AWS because it's XEN based...gbrown is that your understanding too?
Flags: needinfo?(gbrown)
Yes, that's my understanding (but I am not 100% sure).
Flags: needinfo?(gbrown)
(Assignee)

Comment 7

3 years ago
So I looked at this bug in a bit more detail
It seems we would need another emulator image to run it without kvm and according to ateam this would slow things down.  So not sure it is worth pursuing.

As an aside, only set 4 is enabled currently, contrary to the remarks in comment 1
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.