No audio in MP4 playback (MediaCodec) on Aurora (35.0a2); MP4/AAC also broken

VERIFIED DUPLICATE of bug 1101225

Status

()

Firefox for Android
Audio/Video
VERIFIED DUPLICATE of bug 1101225
3 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: snorp)

Tracking

({regression, reproducible})

35 Branch
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox34 fixed, firefox35 verified, firefox36 verified, fennec34+)

Details

(URL)

(Reporter)

Description

3 years ago
Currently Aurora (35.0a2) decodes video via Media Codec (MP4) fine but there is no audio in the stream.

Using our all-time favourite video: http://people.mozilla.org/~atrain/mobile/tests/test.mp4

E/SoftAAC2( 9914): Not enough audio data for the complete frame. Got 100 bytes, frame size according to the ADTS header is 867 bytes.
I/hexdump ( 9914): 00000000:  de 04 00 00 6c 69 62 66  61 61 63 20 31 2e 32 38  ....libfaac 1.28
I/hexdump ( 9914): 00000010:  00 00 42 4d 1f ff ff fe  3d 8a 84 22 8b 15 11 25  ..BM....=.."...%
I/hexdump ( 9914): 00000020:  b5 59 7d 6f 38 8d b8 9d  f0 3c 7c 7c 73 f1 cf c7  .Y}o8....<||s...
I/hexdump ( 9914): 00000030:  3e 99 ff c0 fd 43 e2 1a  03 ed f6 fb 61 f6 c3 ed  >....C......a...
I/hexdump ( 9914): 00000040:  f6 bb ee 7c be 4f f0 1b  7e ea 1b 78 3e ef b8 12  ...|.O..~..x>...
I/hexdump ( 9914): 00000050:  d0 1f 1f f0 06 f6 08 61  82 83 cb d4 0b 9f 8e 72  .......a.......r
I/hexdump ( 9914): 00000060:  96 54 00 07                                       .T..
E/ACodec  ( 9914): [OMX.google.aac.decoder] ERROR(0x8000100b)
E/ACodec  ( 9914): signalError(omxError 0x8000100b, internalError -2147483648)
E/MediaCodec( 9914): Codec reported err 0x8000100b, actionCode 0, while in state 6
I/Gecko   ( 9914): exiting decoder loop due to exception while dequeuing output
I/OMXClient( 9914): Using client-side OMX mux.
E/OMX-VDEC-1080P(  194): Omx_vdec::Comp Init Returning failure, errno 12
E/        (  194): 
E/        (  194):  Destroy C2D instance
E/        (  194): 
E/        (  194):  Destroy C2D instance
E/OMX     (  194): FAILED to allocate omx component 'OMX.qcom.video.decoder.avc'
W/ACodec  ( 9914): Allocating component 'OMX.qcom.video.decoder.avc' failed, try next one.
E/OMXMaster( 9914): A component of name 'OMX.qcom.audio.decoder.aac' already exists, ignoring this one.
E/OMXNodeInstance( 9914): OMX_GetExtensionIndex OMX.google.android.index.storeMetaDataInBuffers failed
E/ACodec  ( 9914): [OMX.google.h264.decoder] storeMetaDataInBuffers failed w/ err -2147483648

What is fixed on Nightly (mozilla-central) here that is needed on Aurora?
(Reporter)

Comment 1

3 years ago
Also spotted

V/MPEG4Extractor( 9914): MPEG4Extractor::countTracks: 2 tracks
W/AudioTrack( 9914): AUDIO_OUTPUT_FLAG_FAST denied by client
D/audio_hw_primary(  194): disable_audio_route: reset and update mixer path: low-latency-playback
D/audio_hw_primary(  194): disable_snd_device: snd_device(2: speaker)
(Reporter)

Updated

3 years ago
See Also: → bug 1100064
(Reporter)

Updated

3 years ago
Version: Firefox 36 → Firefox 35
(Reporter)

Comment 2

3 years ago
MP4/AAC is also completely broken on Aurora

http://people.mozilla.org/~atrain/mobile/tests/test2.mp4
Summary: No audio in MP4 playback (MediaCodec) on Aurora (35.0a2) → No audio in MP4 playback (MediaCodec) on Aurora (35.0a2); MP4/AAC also broken
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1101225
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 1101225 ***

Snorp, is this a true DUPE or will this bug be fixed by bug 1101225? I see it just landed on Aurora.
status-firefox34: --- → unaffected
tracking-firefox35: --- → ?
tracking-fennec: ? → 34+
status-firefox34: unaffected → fixed
status-firefox35: affected → fixed
status-firefox36: unaffected → fixed
tracking-firefox35: ? → ---
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

2 years ago
Keywords: regressionwindow-wanted
Reproduced the issue with 18-11 Aurora build.
Verified as fixed on Firefox for Android 36 Beta 6, using Nexus 4 (Android 4.4.2)
status-firefox36: fixed → verified
http://people.mozilla.org/~atrain/mobile/tests/test.mp4 works ok on Firefox for Android 35.0.1 using Nexus 4 (Android 4.4.2).
status-firefox35: fixed → verified
You need to log in before you can comment on or make changes to this bug.