If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Reply to Sender Only" is misleading and needs to be reworded

RESOLVED WONTFIX

Status

SeaMonkey
MailNews: Message Display
RESOLVED WONTFIX
16 years ago
12 years ago

People

(Reporter: Helge Hielscher, Assigned: jglick)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When I right click on a message and select "Reply to Sender Only" I get a 
Compose Window with "To:reply_to_header_adress".

What I expected was "To: from_adress".
(from and reply_to are the mail headers)

I use mozilla 0.9.5.

Updated

16 years ago
QA Contact: esther → sheelar

Comment 1

16 years ago
reporter,
Which build id are you using?
I am using 2001-11-14-06 build on linux.  worksforme
Reply to sender only sets the correct recipient as To: sender address.
Can you try on a recent build.

If you are still seeing this please give the build id and steps for me to 
reproduce.  
(Reporter)

Comment 2

16 years ago
Well I tried a new build (2001-11-15-06-0.9.6, 2001111506) and it behaves the 
same.
Steps to reproduce:
1) choose a mail with From:a@x.com and Reply-To:b@x.com (my mail has a To: 
b@x.com too, but that shouldnt make any difference)
2) right click on the message and select "Reply To Sender Only"
3) mozilla opens a mail composer window with To:b@x.com

Comment 3

16 years ago
Looks like this is behaving as it should.
For example: compose new message
From: a@x.com
To:   b@x.com
reply-to: b@x.com(setting the reply-to in the compose window, you are saying
when you reply to this email it should be replied to the b@x.com account instead
of a@x.com account which is the sender.)

So receive this message and right click and reply to sender only should reply to
b@x.com which is correct because you have already set while composing that you
want reply to go to b@x.com and not a@x.com even though a@x.com is the sender.

I hope that I am being clear. If you try the same scenario in 4.x you will see
th e same results and this is behaving correclty. This bug is invalid.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
First, the reason why I hope it would work with "Reply To Sender Only" was, that
I am subscribed to some mailing lists and per default the reply goes to the list.
What I need is a function to reply to the real sender.

I see no reason why "Reply", "Reply All" from the toolbar and "Reply To Sender
Only" and "Reply To All" from the context menu do all reply to the address given
by the reply-to field in the refering message.

I am going to post this to the n.m.p.mail-news group for discussing the best
place for this function.
Severity: normal → enhancement
OS: Linux → All
Hardware: PC → All
Summary: Reply to Sender Only doesnt work when Reply-To in Mail → [RFE] Reply to Sender Only should work when Reply-To in Mail

Comment 5

16 years ago
Sure then this can be a request for enhancement. Sorry this has been working 
like this and the reason I marked it invalid is because this was logged as a 
bug.  
As per reporter's last comments will reopen the bug since this is a request for 
enhancement. I will leave it to the UI and engineer to look into this further. 
Status: RESOLVED → UNCONFIRMED
Component: Mail Window Front End → Composition
Resolution: INVALID → ---

Comment 6

16 years ago
reassign
Assignee: sspitzer → ducarroz
Confirming RFE.  Though 'sender' is defined as the e-mail where the message came
from, not the 'reply-to' header.  Personally, I think this is INVALID
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 8

16 years ago
This is in fact a bug. "Reply to Sender Only" activates the Reply feature which
obeys the Reply-To header. The fact that the spec states that the context menu
item should be labeled "Reply to Sender Only" is a bug in the spec. Reassigning
to spec author.
Assignee: ducarroz → jglick
Severity: enhancement → normal
Status: ASSIGNED → NEW
Summary: [RFE] Reply to Sender Only should work when Reply-To in Mail → "Reply to Sender Only" is misleading

Updated

16 years ago
Component: Composition → Mail Window Front End

Comment 9

16 years ago
The spec is here:
http://mozilla.org/mailnews/specs/threepane/MailMenus.html#Context

It states that the context menu entry should be labeled "Reply to Sender".
(Assignee)

Comment 10

16 years ago
I'm not clear on what you are asking to be changed in the spec...

Comment 11

16 years ago
"Reply to Sender" should be changed to "Reply" or "Reply to the message" so it
matches the description used other places where this functionality can be
accessed, such as the toolbar and the Message menu. "Reply to Sender" is not an
accurate description of this functionality since the reply will not always (in
the case of a Reply-To header) go to the sender.
(Assignee)

Comment 12

16 years ago
The "Reply" button in the toolbar does the default action of replying to the 
newsgroup (the appropriate default for newsgroups), so we can't use "Reply" in 
the menus to mean Reply to the Sender/Reply-to-header. Since there are 3 
difference types of Replies for newsgroups, the menu items try to distinguish 
between them, Reply to Sender vs Reply to Newgroup vs Reply to All (sender, 
newsgroups, recipients). I'm not sure what we could change "Reply to Sender" to 
in order to meet your concern. 

Comment 13

16 years ago
changing QA contact from Sheela to Gregg
QA Contact: sheelar → meehansqa

Comment 14

15 years ago
I just got bit by this, in mozilla 1.2 alpha.

I wanted to send a private message to the administrator of a mailing list. I did
a "reply to sender only", and the message went out to the mailing list, much to
my surprise !

This is at the very least a privacy issue, as it can involuntarily cause data to
be leaked to the wrong recipients.

I think this is a serious bug which should have a priority assigned.

It appears that there is no way currently to reply to the sender only with the
built-in functions of Mozilla mail.

"Reply to sender only" in the context menu has the same functionality as the
"reply" button. Obviously the wording of the context menu is incorrect and
should just be "reply".

For "reply all", the wording in both the buttons and the menu are consistent
with what's expected.

This bug is clearly for changing the wording of the menu to be more accurate,
according to the title.

Is there a separate bug filed for the functionality I and the original reported
of this bug need, namely to be able to reply to the person in the "from" field ?

Currently to achieve this, one needs to :
- copy the from address to the clipboard with right-lick/copy email address
- hit reply
- manually highlight the entire content of the "to" field
- right-click and select "paste" to paste the email address.

This all should be possible to achieve in a one-click command.
Summary: "Reply to Sender Only" is misleading → "Reply to Sender Only" is misleading and needs to be reworded
Julien, where you replying from a newsgroup or from a pop/imap account? Do you
mind sending me the message (use forward as attachment). Thanks

Comment 16

15 years ago
JGlick: In the newsgroup the reply button should reply to the sender of the
posting by default.To followup to the newsgroup there should be a seperate
followup button. So Reply to Sender Only does not make sense even in the
newsgroup context.

For the mail context see bug 170191 for an enhancement which allows you to
override the reply-to header. I think it is an important functionality that
Mozilla Mail is missing!

Comment 17

15 years ago
I'm hitting this bug too, on OS X. I've unintentionally sent some sensitive
email to an entire email list. "Embarressing", you might say.

Note that netscape 4.X has this same misleading behaviour.

Does anyone plan to do anything about it? It's been a long time since anyone
commented on this. It has to be a high visibility problem.

Max.
Product: Browser → Seamonkey

Comment 18

13 years ago
Another long interval between comments. I'm researching a different problem and
read this. I see that some comments didn't distinguish between mailing lists and
newsgroups. The original reporter was talking about using mailing lists (email). 

Right-clicking a message gives the context menu with the choice "Reply to Sender
Only", and selecting that puts the mailing-list address in the Reply window, not
the address of the original sender.

To actually reply to the sender, not the list, in a mailing list, I just
manually clear the address field in the reply-to compose window, and enter the
address of the intended recipient.

Has this bug been marked "won't fix"?

Comment 19

12 years ago
Just posting to keep the "expire" monster at bay

Comment 20

12 years ago
> Has this bug been marked "won't fix"?

WRT the summary, the bug is WONTFIX, since for normal email it's intended behaviour. OTOH, we really still suck in mailing list handling - but that's covered by bug 45715/bug 233417.

Status: NEW → RESOLVED
Last Resolved: 16 years ago12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.