Firefox Developer Edition shows list numbers despite list-style: none

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
4 years ago
9 months ago

People

(Reporter: Kei, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.122 Safari/537.36

Steps to reproduce:

ol, ul, li {list-style:none;}
li {display:inline-block;}






Actual results:

<ul><li></li></ul> is being rendered as a numbered list. 

Can't get rid of the numbers even though I have ol with no list-style



Expected results:

There should be no numbers in the list.
Normal Firefox renders it correctly.
(Reporter)

Updated

4 years ago
Keywords: css3

Comment 1

4 years ago
I can't reproduce on beta, dev edition, or nightly, with this testcase:

http://jsbin.com/vowoluyowo/1/edit?html,css,output

Can you provide a testcase with which you can reproduce? And can you provide the date of your dev edition copy? (available under the "About" entry in the app menu on the OS X menubar)
Component: Untriaged → Untriaged
Flags: needinfo?(kei.park)
Keywords: css3 → regression, regressionwindow-wanted, testcase-wanted
Product: Firefox → Core

Updated

4 years ago
Summary: Firefox Developer Edition does not render CSS correctly → Firefox Developer Edition shows list numbers despite list-style: none
Gijs' jsbin example doesn't reproduce for me either, including an Fx35 build from the time this was reported. Resolving this as worksforme given the lack of a reproducible testcase. Feel free to reopen the bug, Kei, if you can provide a testcase that reproduces the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kei.park)
Keywords: regressionwindow-wanted, testcase-wanted
Resolution: --- → WORKSFORME
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.