Closed Bug 1101412 Opened 5 years ago Closed 5 years ago

Intermittent JavascriptException: JavascriptException: TypeError: window.wrappedJSObject.app.inputContext is null

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: cbook, Assigned: Bebe)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

b2g_ubuntu64_vm b2g-inbound opt test gaia-ui-test-functional-1

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=862224&repo=b2g-inbound

20:01:38 ERROR - TEST-UNEXPECTED-ERROR | test_browser_lan.py TestBrowserLAN.test_browser_lan | JavascriptException: JavascriptException: TypeError: window.wrappedJSObject.app.inputContext is null
QA Whiteboard: [fxosqa-auto-backlog+]
Assignee: nobody → robert.chira
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-s5]
Zac, can you assist on this one? It's a PITA to star.
Flags: needinfo?(zcampbell)
I'm not sure what to do here. It really looks like the keyboard app is crashing but it's not a 'known' thing. I'll run it a bit locally and see what I can get.
Flags: needinfo?(zcampbell)
I ran the test locally 100 times and I was not able to reproduce the issue. I don't know what caused the keyboard to close.
Attached video Screencast
I ran this a few times and if we change focus from the b2g app to some other window I'm able to reproduce the exact fail.
The issue is that the keyboard app is closing when we change focus and we can't interact with it any more

If we run the test without changing focus then all works as expected
This should not happen on the slaves

Zac do you have any suggestions on how to prevent this issue?
Flags: needinfo?(zcampbell)
Mdas do you know if we can run the tests in a headless window?
Flags: needinfo?(mdas)
But the focus should never switch from desktop B2G to another application. That would be a receipt for failures anyway.
Perhaps Marionette should bail out directly when that happens?
(In reply to Florin Strugariu [:Bebe] from comment #9)
> 
> Zac do you have any suggestions on how to prevent this issue?

No, but it can be replicated manually so let's file it as a real bug against desktopb2g.
Flags: needinfo?(zcampbell)
I spoke to timdream about it and he suggested trying running the test in a virtual buffer or applying focusmanager.testmode, which we already do.
Flags: needinfo?(mdas)
Assignee: robert.chira → florin.strugariu
QA Whiteboard: [fxosqa-auto-s5] → [fxosqa-auto-s5][fxosqa-auto-s6]
QA Whiteboard: [fxosqa-auto-s5][fxosqa-auto-s6] → [fxosqa-auto-from-s5][fxosqa-auto-s6]
Depends on: 1109555
I'm not convinced that this means that b2g is losing focus. The same stack trace does not mean that the action you have performed has caused it. The stacktrace we have here is quite generic and any number of issues in the test could cause it.
Closing this as works for me.

If this fails again please reopen the bug
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.