Default activities behavior for apps not implementing all the activities for the same action . Follow up 1073495

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: davidg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
+++ follow up Bug #1073495 +++

In bug 1039386 it is described that certain activities are grouped together as the same action, so if a set an application as default for an activity, the application will be set as default for all activities under that action.

For example:
'open', 'new' and 'update' activities for type 'webcontact', are defined as the 'Open contact' action.
So if I set an application as default for 'open' 'webcontact', that application should be set as default for 'new' and 'update' too.

The problem is, if an application only supports 'open' and I set it as default, it will be set as default for 'update' and 'new' too, but the application doesn't support them.
In the current implementation, for that particular case, the user will be ask to select an application again.
Depends on: 1141479

Comment 1

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.