[Flame][FM Radio]Radio will pause after you stop an alarm.

RESOLVED DUPLICATE of bug 1079555

Status

Firefox OS
Gaia::FMRadio
RESOLVED DUPLICATE of bug 1079555
3 years ago
3 years ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(3 attachments)

9.17 MB, video/mp4
Details
104.28 KB, text/plain
Details
262.31 KB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8525238 [details]
video

[1.Description]:
[Flame][v2.1&v2.2][FM Radio]Radio will pause and can't play back automatically after you stop an alarm. 
Attachment:04:09
Occurrence time:VIDEO_0409.MP4 & LOGCAT_0409.TXT

[2.Testing Steps]: 
1.Set an alarm via clock.
2.launch FM Radio and play.
3.Waiting alarm come.
4.Stop alarm.

[3.Expected Result]: 
4.FM radio play back automatically.

[4.Actual Result]: 
4.FM radio pause.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141118001204
Version         34.0

Flame 2.2 build:
Gaia-Rev        4aee256937afe9db2520752650685ba61ce6097d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/084441e904d1
Build-ID        20141118144012
Version         36.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8525239 [details]
logcat
This appears to be a dupe of bug 1079555
(Reporter)

Comment 3

3 years ago
Created attachment 8545061 [details]
logcat_1447.txt

Hi Eric,
This issue can be repro on Flame 2.1/2.2, but it can not be repro on Woodduck 2.0M and Flame 2.0, I have uploaded the logcat of Flame 2.2, could you help with it? Thanks!
Found time:14:47
See attachment:logcat_1447.txt

Flame 2.0 build:
Gaia-Rev        f76014fd2c7528493b90d759c68ec3070233d094
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/aedeb9e38bb9
Build-ID        20150106000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034857
FW-Date         Tue Jan  6 03:49:08 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150106001308
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034709
FW-Date         Tue Jan  6 03:47:20 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2a193b7f395c
Build-ID        20150106010234
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.043413
FW-Date         Tue Jan  6 04:34:26 EST 2015
Bootloader      L1TC000118D0

Woodduck build:
Gaia-Rev        06b544f8a9ee03754dd3f5020f279cffa7a75804
Gecko-Rev       6b1e24a1cba1d5542bebb503ce05a1ec61ceb7d3
Build-ID        20150107050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1420578377
FW-Date         Wed Jan  7 05:06:46 CST 2015
Flags: needinfo?(echang)
(Reporter)

Updated

3 years ago
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → unaffected
Radio not resume after
Flags: needinfo?(timdream)
Flags: needinfo?(pzhang)
Flags: needinfo?(echang)
Radio not resume after stopping alarm, not sure this is spec or bug, radio issue or clock one.
(In reply to Eric Chang [:ericcc] [:echang] from comment #4)
> Radio not resume after

What are you trying to ask?
Flags: needinfo?(timdream)
Flags: needinfo?(pzhang)
Per comment 2.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079555
You need to log in before you can comment on or make changes to this bug.