Use san-serif ClearType fonts for East Asian languages in Windows Vista or later by default

RESOLVED DUPLICATE of bug 1016792

Status

()

defect
RESOLVED DUPLICATE of bug 1016792
5 years ago
5 years ago

People

(Reporter: tuanese, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

Open East Asian languages page.


Actual results:

Webpages are rendered with old fonts that do not look nice when DirectWrite is enabled.


Expected results:

For Windows Vista and later.

Use Microsoft YaHei as default san-serif font for Simplified Chinese.
Use Microsoft JhengHei as default san-serif font for Traditional Chinese Hong Kong and Taiwan.
Use Meiryo as default san-serif font for Japanese.
Use Malgun Gothic as default san-serif font for Korean.

This is already executed by Internet Explorer (in Windows 8 or later) by default.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016792
You need to log in before you can comment on or make changes to this bug.