drag/drop re-positioning in Manage Bookmarks does not work at top level

VERIFIED DUPLICATE of bug 107422

Status

--
major
VERIFIED DUPLICATE of bug 107422
17 years ago
14 years ago

People

(Reporter: jim.avera, Assigned: paulkchen)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Linux Build ID: 2001113114.  Running gnome (ximian gnome 1.4)

Can not re-position top-level bookmarks using the Manage Bookmarks dialog.

If you grab a bookmark at the top level
and drag it, it seems to work until you let go of the mouse button (button #1),
at which point a "flying back where it came from" animation is shown and
the bookmark ordering remains unchanged.  But you *can* move bookmarks
inside a folder, such as the Personal Toolbar folder.

This is easily reproducible using a completely clean state:

Steps to reproduce:
1. Move aside $HOME/.mozilla so .mozilla does not exist.
2. Run mozilla
3. Bookmarks->Add Bookmark
4. Visit two additional pages and do Bookmarks->Add Bookmark
5. Bookmarks->Manage Bookmarks
6. Grab the bottom-most bookmark and drag it up so the thin horizontal
   line (the drop-position indicator) is one slot higher.
7. Release the mouse button.  The bookmark is not moved.
8. Repeat, but try moving a bookmark inside the Personal Toolbar folder;
   that works.

Expected results: 
  Should be able to move any bookmark, even top-level bookmarks.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 107422 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
*** Bug 112334 has been marked as a duplicate of this bug. ***
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.