Closed Bug 1101538 Opened 6 years ago Closed 5 years ago

Add Estonian ID-card digital signature plugin to whitelist

Categories

(Firefox Graveyard :: Plugin Click-To-Activate Whitelist, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: anton, Assigned: benjamin)

Details

<<Please supply the following information for new plugin whitelist requests>>

Plugin name: EstEID Firefox plug-in
Vendor: RIA www.ria.ee developer SK www.sk.ee general ID Software page www.id.ee
Point of contact: abi@id.ee
Current version: 3.8
Download URL: General url for downloading whole ID-software including plugin https://installer.id.ee/
Ubuntu plugin download https://installer.id.ee/media/ubuntu/pool/main/e/esteidfirefoxplugin/
Sample URL of plugin in use:  https://openxades.org/web_sign_demo/sign.html (in Estonian language)
source code 
https://svn.eesti.ee/projektid/idkaart_public/trunk/esteid-plugin/

Plugin details: Used for digital signing with Estonian ID-card in Firefox browser

<<For each affected operating system, please copy the plugin information from about:plugins in Firefox>>
EstEID Firefox plug-in

    File: npesteid-firefox-plugin.dll
    Path: C:\Program Files (x86)\Estonian ID Card\npesteid-firefox-plugin.dll
    Version: 3.8.0.1115
    State: Enabled
    Allows digital signing with Estonian ID cards

MIME Type	Description	Suffixes
application/x-digidoc		
application/x-idcard-plugin	

EstEID plug-in

    File: npesteid-firefox-plugin.so
    Path: /usr/lib/mozilla/plugins/npesteid-firefox-plugin.so
    Version: 3.8.0.1115
    State: Enabled
    Allows digital signing with Estonian ID cards

MIME Type	Description	Suffixes
application/x-digidoc	EstEID plug-in

EstEID Firefox plug-in

File: esteidfirefoxplugin.bundle
Path: /Library/Internet Plug-Ins/esteidfirefoxplugin.bundle
Version: 1.20
State: Enabled
Allows digital signing with Estonian ID cards
MIME Type	Description	Suffixes
application/x-digidoc	EstEID Firefox plug-in	

Are there any variations in the plugin file name, MIME types, description, or version from one release to the next?
No, No, No, Yes

Are there any known security issues in current or older versions of the plugin?
No
Basically this is an update to this ticket Bug 982045.
We will be shutting down the plugin whitelist, and are not accepting new applications or renewals. I'm going to close this bug as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.