Convert all arbitrary content <tree>s to <listbox>

VERIFIED FIXED in mozilla1.0

Status

()

defect
P1
critical
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: hyatt, Assigned: hewitt)

Tracking

({access})

Trunk
mozilla1.0
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

18 years ago
 
Reporter

Updated

18 years ago
Blocks: 70753
Assignee

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.7
Lovely explanation. What should I do with this tree?
    <tree>
      <treecolgroup flex="1">
        <treecol flex="3"/>
        <treecol flex="2"/>
        <treecol flex="1"/>
      </treecolgroup>

      <treehead>
        <treerow>
          <treecell class="treecell-header treecell-inset-header"/>
          <treecell class="treecell-header treecell-inset-header"/>
          <treecell class="treecell-header treecell-inset-header"/>
        </treerow>
      </treehead>

      <treechildren flex="1">
        <treeitem level="0">
          <treerow>
            <treecell/>
          </treerow>
          <treechildren>
            <treeitem level="1">
              <treerow>
                <treecell/>
                <treecell/>
              </treerow>
              <treechildren>
                <treeitem level="2">
                  <treerow>
                    <treecell/>
                    <treecell/>
                    <treecell>
                      <checkbox/>
                    </treecell>
                  </treerow>
                </treeitem>
              </treechildren>
            </treeitem>
          </treechildren>
        </treeitem>
      </treechildren>
    </tree>
Assignee

Comment 2

18 years ago
neil, that tree should become an outliner (which will actually be called
"tree").  We are going to eventually add support for checkbox cells in outliner.
Assignee

Updated

18 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Updated

18 years ago
Blocks: 112951

Updated

18 years ago
No longer blocks: 112951

Comment 3

18 years ago
what is the status on this?

Updated

18 years ago
Blocks: 119240
Assignee

Updated

18 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Assignee

Comment 4

18 years ago
Posted patch patch for mail compose (obsolete) — Splinter Review
This converts the addressing widget and attachment bucket to use listbox.
Assignee

Updated

18 years ago
Depends on: 70858

Updated

18 years ago
Blocks: 110165

Comment 5

18 years ago
adding keywords inherited from a bug this is blocking. I may have botched the
bug number, if so, someone please rectify.
Keywords: crash, nsbeta1+, topcrash
Assignee

Updated

18 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 6

18 years ago
updating severity to critical since bug 110165 is a blocker.
Severity: normal → critical
Assignee

Comment 7

18 years ago
Attachment #64584 - Attachment is obsolete: true
Assignee

Updated

18 years ago
Blocks: 122666
Comment on attachment 68208 [details] [diff] [review]
mail compose patch, take 2

don't forget to fix the Attachment2 [details] [diff]CompFields function which is not able to
retreive the attachment. R=ducarroz
Attachment #68208 - Flags: review+
Assignee

Comment 9

18 years ago
Removing crash keywords. I think there was some confusion between this bug and
110165.
Keywords: crash, topcrash

Updated

18 years ago
Keywords: mozilla1.0+

Comment 10

18 years ago
cc aaronl, add access keyword
Keywords: access

Updated

18 years ago
No longer blocks: 110165
Assignee

Updated

18 years ago
Depends on: 130422
Assignee

Updated

18 years ago
Depends on: 130679

Updated

18 years ago
Whiteboard: [adt1]

Comment 11

18 years ago
Today, I tried the build at http://www.joehewitt.com/mozilla/treetest.zip
So far:
1. Sidebar Search: clicking on an item in the Search Result list does not load
the page.
2. Advanced Search (internetresults.xul): internet site and search engine
columns are empty. 
Wouldn’t it be possible to convert the old tree in outliner instead of a
listbox? It would add the possibility to resize the columns, remove some rows,
etc... 
With the current build, clicking on a header (in order to sort) messes (up-down)
the listbox window with the result window.
3. Mail: double click on an item in the mail attachment list does not load the
attachment
Chanign to ADT2 per ADT triage.
Whiteboard: [adt1] → [adt2]
> 3. Mail: double click on an item in the mail attachment list does not load the
> attachment

this has been fixed since that builds was posted on joehewitt.com

At least, it works for me in my build.
*** Bug 87935 has been marked as a duplicate of this bug. ***
*** Bug 76552 has been marked as a duplicate of this bug. ***
Assignee

Comment 16

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED

Comment 17

16 years ago
It's been a long, long, long time running...
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.