Closed Bug 1101595 Opened 5 years ago Closed 5 years ago

[shadow-dom] <input> doesn't emit 'input' event when inside shadow-root

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: wilsonpage, Assigned: smaug)

References

Details

Attachments

(1 file)

It seems `<input type=text />` elements inside a shadow-root don't seems to dispatch 'input' events. 

TEST CASE

http://jsbin.com/dusano/1/
Assignee: nobody → bugs
Attached patch patchSplinter Review
Attachment #8525382 - Flags: review?(wchen)
Duplicate of this bug: 1101612
Attachment #8525382 - Flags: review?(wchen) → review+
https://hg.mozilla.org/mozilla-central/rev/3b98db519502
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.