Closed Bug 1101650 Opened 5 years ago Closed 5 years ago

Toolbox disappears(whole browser turn black) temporarily during display transition

Categories

(Core :: Graphics: Layers, defect)

36 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 + fixed

People

(Reporter: alice0775, Assigned: BenWa)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]: regression since Nightly36


Steps To Reproduce:
1. Start Nightly without title bar
2. Open https://www.mozilla.org/en-US/firefox/nightly/firstrun/
3. Scroll to downward approx. 200-400px
4. Open https://www.mozilla.org/en-US/firefox/34.0/firstrun/
5. Click [x] button on "Take a quick tour" arrow panel immediately
6. Repeat step2 - step5 if necessary 

Actual Results:
Toolbox disappears temporarily during display transition

Expected Results:
Toolbox should not disappear. 
The transition should be performed only in the content area.
Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/3457abba4f2a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141118170224
Bad:
https://hg.mozilla.org/mozilla-central/rev/64e7a6391916
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141118180824
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3457abba4f2a&tochange=64e7a6391916


Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/52f500342c88
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141118080527
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d1469442b5f7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141118083228
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=52f500342c88&tochange=d1469442b5f7

Suspect:
1608ca65d899	Benoit Girard — Bug 1087530 - Retain container's intermediate surfaces for up to one frame. r=jmuizelaar
Blocks: 1087530
Flags: needinfo?(bgirard)
Keywords: regression
Component: Layout → Graphics: Layers
Summary: Toolbox disappears temporarily during display transition → Toolbox disappears(whole browser turn black) temporarily during display transition
Thanks Alice. I've already found a problem with the state management that's specific to OpenGL. There might be a similar bug on windows. Taking a look now.
Assignee: nobody → bgirard
Alice can you post the about:support (looking for the Layers backend you're using)?
Flags: needinfo?(alice0775)
Graphics
--------

Adapter Description: AMD Radeon HD 6450
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 1024
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
Device ID: 0x6779
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 9-15-2014
Driver Version: 14.301.1001.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 23111787
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(alice0775)
BLAH! I think it's a logic error:
http://mxr.mozilla.org/mozilla-central/source/gfx/layers/d3d11/TextureD3D11.cpp#661

Waiting for my environment to update to test the fix. I can reproduce it easily.
Attached patch patchSplinter Review
Flags: needinfo?(bgirard)
Attachment #8525544 - Flags: review?(jmuizelaar)
That's it, verified the fix before/after locally.
Attachment #8525544 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/5f46b1defca5
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Duplicate of this bug: 1102189
You need to log in before you can comment on or make changes to this bug.