location after perssing "Not Now" timeout error does not fired

RESOLVED DUPLICATE of bug 675533

Status

()

Core
Geolocation
--
major
RESOLVED DUPLICATE of bug 675533
3 years ago
3 years ago

People

(Reporter: Alex Art, Unassigned)

Tracking

34 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141117202603

Steps to reproduce:

var OPTIONS = { maximumAge: 3000, timeout: 5000, enableHighAccuracy: true };
					/**
					 * Use to get GeoLocation
					 * @returns {undefined}
					 */
					var getLoc = function() {
						var deferred = $q.defer();
						if (navigator.geolocation)
							navigator.geolocation.getCurrentPosition(function(data) {
								console.log(data);
								deferred.resolve(data);
							}, function(error) {
								console.log(error);
								deferred.reject(error);
							}, OPTIONS);
						else {
							console.log("AIIIII");
							deferred.reject({ error: "GPS OFF", gpsOn: false });
						}

getLoc();


Actual results:

Nothing happens.


Expected results:

according to W3C "The getCurrentPosition() method takes one, two or three arguments. When called, it must immediately return and then asynchronously attempt to obtain the current location of the device. If the attempt is successful, the successCallback must be invoked (i.e. the handleEvent operation must be called on the callback object) with a new Position object, reflecting the current location of the device. If the attempt fails, the errorCallback must be invoked with a new PositionError object, reflecting the reason for the failure."

so error function must be called, with timeout error.
Component: Untriaged → Geolocation
Product: Firefox → Core
"Not Now" is not an error, it's a UI mechanism to close the prompt without making a decision... The user can reopen the prompt to explicitly allow/deny is desired.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Updated

3 years ago
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 2

3 years ago
It's not resolved.
It is improper spec implementation.
(Reporter)

Comment 3

3 years ago
Whatever user does it does not matter the getCurrentPosition() method  must invoke errorCallback on timeout!
Read specs please.
You are making developers very unhappy with this.
This bug persists.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Updated

3 years ago
Severity: critical → major
Priority: P1 → --
(Reporter)

Comment 4

3 years ago
sorry for changing priority - bad habit from projects i lead.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675553
(Reporter)

Comment 6

3 years ago
 Josh Matthews. Sorry for disturbing, But can you exactly explain how this bug and  bug 675553 are connected?
Thanks in advance?

Updated

3 years ago
Duplicate of bug: 675533
You need to log in before you can comment on or make changes to this bug.