Closed Bug 1101742 Opened 5 years ago Closed 5 years ago

OmxDecoder::mIsVideoSeeking becomes false during video seeking

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

(Keywords: branch-patch-needed, regression)

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1099356 +++

During video seeking in  OmxDecoder::ReadVideo(), OmxDecoder::mIsVideoSeeking could become false. It should be true.
Assignee: nobody → sotaro.ikeda.g
This bug is a regression of Bug 1059661.
Blocks: 1059661
Keywords: regression
[Blocking Requested - why for this release]: This bug is a regression of b2gv2.0+ bug(Bug 1059661). This bug cause a crash during video seeking.
blocking-b2g: --- → 2.0?
Attachment #8525485 - Flags: review?(cajbir.bugzilla)
Attachment #8525485 - Flags: review?(cajbir.bugzilla) → review+
blocking-b2g: 2.0? → 2.0+
https://hg.mozilla.org/mozilla-central/rev/59f78368b454
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Comment on attachment 8525485 [details] [diff] [review]
patch - Fix  OmxDecoder::mIsVideoSeeking

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1059661
User impact if declined: application could crash during seeking video.
Testing completed: locally tested.
Risk to taking this patch (and alternatives if risky): low risk. 
String or UUID changes made by this patch: none.
Attachment #8525485 - Flags: approval-mozilla-b2g34?
Attachment #8525485 - Flags: approval-mozilla-b2g32?
Attachment #8525485 - Flags: approval-mozilla-b2g34?
Attachment #8525485 - Flags: approval-mozilla-b2g34+
Attachment #8525485 - Flags: approval-mozilla-b2g32?
Attachment #8525485 - Flags: approval-mozilla-b2g32+
I'm trying to land this on b2g34 and b2g32, but the /dom/media/omx/ directory doesn't seem to exist on these branches. Do we need branch patches for this, or do we not even need this on b2g32/34?
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Wes Kocher (:KWierso) from comment #8)
> I'm trying to land this on b2g34 and b2g32, but the /dom/media/omx/
> directory doesn't seem to exist on these branches. Do we need branch patches
> for this, or do we not even need this on b2g32/34?

This folder is recently move from  /content/media/omx.
Flags: needinfo?(sotaro.ikeda.g)
KWierso, I created a patch for b2g v2.1. It should work also for b2g v2.0.
Flags: needinfo?(kwierso)
Flags: needinfo?(sotaro.ikeda.g)
You need to log in before you can comment on or make changes to this bug.