[Browser] The "requires an internet connection" error page appears cutoff on landscape and portrait

RESOLVED INVALID

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Petes, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3] [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8525484 [details]
ri.txt

Description:
When downloading an app without internet connection, the "requires an internet connection" error page appears cutoff on landscape and portrait
  
Repro Steps:
1) Update a Flame device to BuildID: 20141119001205
2) Go to marketplace > Tap an app > tap free.
3) Disable wifi from the notifications screen. 
4) Rotate phone to landscape, tap install
5) Go to homescreen, open the app
  
Actual:
The button appears cutoff
  
Expected: 
The button is display correctly 
  
Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141119001205
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Note: User can still see the bottom button when scrolling down

  
Repro frequency: 3/3, 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8525486 [details]
2014-11-19-10-40-31.png
(Reporter)

Comment 2

4 years ago
This issue also reproduces on the Flame 2.2, the button appears cutoff

Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

------------------------------------------------------------------------------------------------------------

This issue does reproduce on the Flame 2.0, the button is display correctly 

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141119000207
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
There is more traction in Bug 1093388 regarding the landscape issue - this bug seems to be a dupe of that except for the fact that bug doesn't mention portrait.
I believe this is invalid based upon bug 1058637

The user can scroll the page so technically it is not cutoff.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.