[Window Mgmt] Options in the reel picker/menu are saved without selecting OK

RESOLVED DUPLICATE of bug 937571

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 937571
4 years ago
4 years ago

People

(Reporter: CorinneI, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8525514 [details]
Menu logcat.txt

If the user selects an option in any reel picker, without selecting OK, the last selected option will be saved when the screen times out, device powers off, and if home button is tapped or long pressed. This will happen anywhere from the Settings app, Clock, Calendar, to even the FTE/FTU. 
   
Repro Steps:
1) Update a Flame device to BuildID: 20141119001205
2) Open Settings>Display
3) Tap on the reel picker for "Screen Timeout"
4) Choose a different option
5) Without tapping "OK" exit the menu (Home button or lock/unlock works the best)
6) Reopen the same page Settings>Display
7) Observe displayed option under "Screen Timeout"
  
Actual:
Last selected option will be saved without tapping OK
  
Expected: 
Should default back to originally selected option if the menu is exited without tapping OK.
  
Environmental Variables:
Device: Flame 2.1 kk (319mb)(Shallow Flash)
BuildID: 20141119001205
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 100%
See attached: Screenshot, Logcat, Youtube Link:
http://youtu.be/hXRSuB_vyqc
Flags: needinfo?(ktucker)
(Reporter)

Comment 1

4 years ago
Created attachment 8525516 [details]
Reel Picker.png

Issue DOES occur on Flame 2.2 and Flame 2.0

Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141119000207
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual:
Last selected option is saved without tapping OK

Notes:
Does NOT happen during FTE/FTU for 2.2 DOES work after the FTE if an aplication is force closed while in a reel picker.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 937571
You need to log in before you can comment on or make changes to this bug.