If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Planet Mozilla Redesign

RESOLVED WONTFIX
(Needinfo from 2 people)

Status

Marketing
Design
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: mhoye, Assigned: Sean Martell, NeedInfo)

Tracking

(Blocks: 1 bug)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
>>Project/Request Title:
Planet Mozilla

>>Project Overview:
Planet Mozilla is our excellent aggregator for all things syndicated and mozillian, but designwise it is getting long in the tooth. It needs some love; specifically it needs the kind of love that talented people can bring to both desktop and mobile viewers with modern sensibilities and current art assets.

>> Creative Help Needed:
Copy:    No 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
Mobile and desktop themes for Planet.Mozilla.Org, with the option of having the various other subplanets get on board if they're so inclined. 

>>CTA and Design:
I'm not even going to try. You people know what you're about here. 

>>Creative Due Date:
2015-04-01

>>Launch Date:
2015-04-01

>>Mozilla Goal:
Million Mozillians

>>Points of Contact:
mhoye@mozilla.com
(Reporter)

Updated

3 years ago
Blocks: 1100039

Comment 1

3 years ago
Hey Mike. Thanks for filing this so far in advance! Sounds like there's some time to figure these details out, but I'll note that we'll need a little more direction before being able to get started. In particular, would need direction on content requirements and functionality, ideally in the form of a wireframe. And, we'd need to have a discussion about the strategy behind the design...what are your goals for the site, desired user behaviors, etc.

So, we do indeed know what we're about, but also can't do it alone.
(Reporter)

Comment 2

3 years ago
>  So, we do indeed know what we're about, but also can't do it alone.

I believe in you.

The beauty of Planet in this context is that the content and functionality is largely generated and reasonably well-understood, respectively; the role of planet certainly won't be changing. Perhaps a better problem description would be: Planet looks dated on desktop and like ass on mobile.

I think that a sensible site to take inspiration from is,  as ever, Metafilter - Lots of articles, but navigation options in sensible places and, on mobile, long menus (and the sidebar full of whatsits) hidden away in favor of simplicity. The Inimitable Mart3ll has pointed me to this logo: 

http://blog.seanmartell.com/wp-content/uploads/2012/03/logo_0028_29.png

And a combination of that vintage-newsreel theme and sane, modern design and navigational options would be very much a welcome refresh.

We can talk about modern navigational tools here as well - I suspect Planet's accessibility is pretty substandard as far as modern expectations go - but I am happy to discuss this at more length. 

Wireframes, you say?
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1108569
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1108438

Comment 5

3 years ago
(John Slater is not part of Mozilla it seems so we need to find a new owner, be in the community or at Mozilla itself.)

So it's a request which comes more often, specifically with more people from the Mozilla community using mobile devices to read content on the go. I have opened Bug 1108438.

The Planet system consists in 
* one Web page 
* aggregating a collection of (Atom, RSS) feeds
* under the form of a time ordered list of blog posts

You can see a couple of examples here and there
 * http://planet.mozilla.org/
 * http://planet.webcompat.com/ (code https://github.com/miketaylr/planet.webcompat.com/)
I will post two screenshots of the current rendering of the two planets on small viewports

Some requirements (as a textual wireframe):
* The title of the planet
* A by-date structure (Most recent at the top)
  with the collection of posts for this date
* For each invidual post:
  - The title of the post with link back to the original blog
  - author
  - date of the post
  - full content of the post
* Atom feed of the planet itself
* Last updated: aka the date when the aggregation has occured.
* List of aggregated blogs
  - Name of blogs and/or authors
  - Link to the blog
  - Link to their individual feed

The design has to be responsive, with probably a focus on mobile content first. Simple is better. This page is just another form of an aggregator without archives. 

Hope it helps.
Flags: needinfo?(alexamroman)
Summary: Planet Mozilla → Planet Mozilla Redesign

Comment 6

3 years ago
Created attachment 8534035 [details]
planet-mozilla.png

The current rendering of Planet Mozilla on a small viewport

Updated

3 years ago

Comment 7

3 years ago
Created attachment 8534037 [details]
planet-webcompat.png

The current rendering of Planet Webcompat on a small viewport.

Comment 8

3 years ago
Hi Karl + Mike, 

We were discussing this bug today. It might be a great project to get Community help. If you don't mind, we will figure this out in the new year.

Comment 9

3 years ago
Jennifer,

Would it be ok if we find someone who would like to do it?
Or is there anything else which is blocking this?

Mike,
What planet engine are you using?
Flags: needinfo?(jbalaco)

Comment 10

3 years ago
Not a problem. We are also in the process of relaunching the Creative Collective which can help find someone.
Flags: needinfo?(jbalaco)
(Reporter)

Comment 11

3 years ago
As far as I know it's stock "planetplanet", but the state of the art may have moved on there. Might be worth reviewing our options.

My main goals for this revamp are "modern Mozilla UI, responsive design on mobile, search works again", but I've got to talk this out with my fellow Planet peers.
(Reporter)

Comment 12

3 years ago
On reflection, we may want to consider a parallel discussion about Planet infrastructure. svn-commit to update seems kind of antiquated, and is turning out to be a pretty brittle thing.

Comment 13

3 years ago
I'd be happy to take a crack at the webcompat one, but Planet Mozilla probably has many more considerations than I can tackle. When you guys get around to discussing this, I would be interested to hear if each planet can have their own style or if it will be finite style guide for all.

Karl, how do blog posts get on the webcompat one? Feels like we should be adding our changelog blog posts here.
Alexa this bug is only for Planet Mozilla, I opened a bug for Planet webcompat
https://github.com/miketaylr/planet.webcompat.com/issues/14
(Assignee)

Comment 15

3 years ago
I'd be willing to have a go at redesigning Planet, but my top concern would be that we'd need to update the underlying layout to resolve several of the overflow issues pointed out in this bug.

Could this be a phased project in that it gets the needed code/layout overhaul using the current CSS stylings and we then skin it as a phase 2?
(Reporter)

Comment 16

3 years ago
I support that approach. Also, I suspect that Planet is not the first mozsite to have this problem, so if we've got assets we can pull off the shelf for phase 1 that would be good.

Updated

3 years ago
Assignee: jbalaco → smartell
Status: NEW → ASSIGNED
Due Date: 2015-04-01 → 2015-04-30
(Assignee)

Comment 17

3 years ago
Just pinging this project to see if any progress has been made on the underlying structure of Planet prior to reskin?

thanks!
(Reporter)

Comment 18

3 years ago
None. I'll discuss it with my fellow peers.

Comment 19

2 years ago
I'm going to close this out for now. When the backend work has been completed, please resubmit. Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Jennifer, are there any benefits to close it? 
It's just a TODO for now.
(In reply to Karl Dubost :karlcow from comment #20)
> Jennifer, are there any benefits to close it? 
> It's just a TODO for now.

Hi Karl,

It really helps our process if we only have open bugs for current, active projects.

As Jennifer says, once the underlying work has been done, that will be the right time to resubmit and engage our team.

Thanks.

Comment 22

2 years ago
Hey Jennifer, 

is there a bug we can follow for the backend stuff? If not, do you have an update on that?
Flags: needinfo?(jbalaco)

Comment 23

2 years ago
Hi Florian, 

Not that I know of - Mike Hoye was working on that.
Flags: needinfo?(jbalaco)

Comment 24

2 years ago
(In reply to Jennifer Balaco from comment #23)
> (In reply to Florian Bender from comment #22)
> > is there a bug we can follow for the backend stuff? If not, do you have an
> > update on that?
> 
> Not that I know of - Mike Hoye was working on that.

Mike, do you know of any bug that can be tracked?
Flags: needinfo?(mhoye)
You need to log in before you can comment on or make changes to this bug.