[Camera] Border in video mode will appear white after closing app through card view

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(2 attachments)

Posted file logcat
Description:
If the user opens the camera app then opens card view and closes camera then the border of video mode will be white when video mode is entered again.

Repro Steps:
1) Update a Flame to 20141119040205
2) Open Camera
3) Open Card view and close camera app
4) Open camera app
5) Switch to video mode
6) Observe borders

Actual:
The borders in video mode are white

Expected:
It is expected that the borders in video mode are black

Environmental Variables:
Device: Flame 2.2 (Shallow Flash)(319mb)
Build ID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5
See attached: screenshot, logcat
--------------------------------------------------------------------------------
This issue occurs on the previous 2.2 Flame.

Environmental Variables:
Device: Flame 2.2 (Shallow Flash)(319mb)
BuildID: 20141118040205
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Result:
The borders in video mode are white
------------------------------------------------------------------------------------
There are not borders present on video made in 2.1.
Posted image White border
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
need info on qa lead for camera for nomination decision.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(npark)
Marked for blocking, since it is a obvious UI failure which is relatively easy to repro.
blocking-b2g: --- → 2.2?
Flags: needinfo?(npark)

Comment 4

5 years ago
Blocking - regression from 2.1
blocking-b2g: 2.2? → 2.2+
I cannot find the bug/changelist which fixed this but I can no longer reproduce on the latest master whereas I could reproduce consistently until recently.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.