Console: command line - autocomplete popup position issue

RESOLVED DUPLICATE of bug 1046861

Status

defect
RESOLVED DUPLICATE of bug 1046861
5 years ago
Last year

People

(Reporter: thomas, Unassigned)

Tracking

(Blocks 1 bug)

28 Branch
x86
All
Dependency tree / graph

Firefox Tracking Flags

(firefox33 affected, firefox34 affected, firefox35 affected, firefox36 affected, firefox-esr31 affected)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141118144012

Steps to reproduce:

Using OS-X, Firefox Nightly 36.0a1 (2014-11-18)

1. Open Nightly
2. Resize the browser window so the width takes half of the screen, position the browser window to the left of your screen.
3. Open Tools -> Web Developer -> Web Console  
4. Type the following example JS: var xpathResult = document.evaluate( 'body/div/div/div/div/div/div/div/div/div/div/div/div/div/div/div/div/div/div/div', document, null, XPathResult.ANY_TYPE,  );

(the xpath selector here may be ridicilous, the point is to have the command line multi lined. Add /div if needed).

5. In the last evaluate() argument, start typing eg. document (so the autocomplete popup shows)





Actual results:

When the command line is 'multi lined' the autocomplete popup is show way of to the  right of the browser window.


Expected results:

The popup should be shown at the caret/insertion point just as when the command line is 'single lined'.

Updated

5 years ago
Component: Untriaged → Developer Tools: Console

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Version: 36 Branch → 28 Branch

Updated

3 years ago
See Also: → 1234085
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1046861

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.