N621 crash [@ .__ptr_glue - output_row ]

VERIFIED WORKSFORME

Status

()

Core
ImageLib
P2
critical
VERIFIED WORKSFORME
17 years ago
4 years ago

People

(Reporter: Jan Carpenter, Assigned: Stuart Parmenter)

Tracking

({crash, topcrash})

Trunk
mozilla1.1alpha
PowerPC
Mac System 9.x
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Non reproducible, crash signature)

(Reporter)

Description

17 years ago
This bug is a topcrasher for N620.

 Count   Offset    Real Signature
[ 13   .__ptr_glue 34fd974d - output_row() ]
 
     Crash date range: 2001-11-06 to 2001-11-12
     Min/Max Seconds since last crash: 32 - 21625
     Min/Max Runtime: 32 - 21625
     Keyword List :  
     Count   Platform List 
     9   MacOS version 9.2.1  
     3   MacOS version 9.1  
     1   MacOS version 9.0.4  
 
     Count   Build Id List 
     13   2001102217
 
     No of Unique Users        13
 
 Stack trace(Frame) 

	 .__ptr_glue  
	 output_row()
[GIF2.cpp  line 198] 
	 do_lzw()
[GIF2.cpp  line 397] 
	 gif_write()
[GIF2.cpp  line 823] 
	 nsGIFDecoder2::ProcessData()
[nsGIFDecoder2.cpp  line 205] 
	 ReadDataOut()
[nsGIFDecoder2.cpp  line 153] 
	 nsInputStreamTee::WriteSegmentFun()
[nsInputStreamTee.cpp  line 78] 
	 nsPipe::ReadSegments()
[nsPipe2.cpp  line 411] 
	 nsInputStreamTee::ReadSegments()
[nsInputStreamTee.cpp  line 134] 
	 nsGIFDecoder2::WriteFrom()
[nsGIFDecoder2.cpp  line 220] 
	 imgRequest::OnDataAvailable()
[imgRequest.cpp  line 793] 
	 ProxyListener::OnDataAvailable()
[imgLoader.cpp  line 465] 
	 nsStreamListenerTee::OnDataAvailable()
[nsStreamListenerTee.cpp  line 56] 
	 nsHttpChannel::OnDataAvailable()
[nsHttpChannel.cpp  line 2224] 
	 nsOnDataAvailableEvent::HandleEvent()
[nsStreamListenerProxy.cpp  line 177] 
	 nsARequestObserverEvent::HandlePLEvent()
[nsRequestObserverProxy.cpp  line 64] 
	 PL_HandleEvent()
[plevent.c  line 590] 
	 PL_ProcessPendingEvents()
[plevent.c  line 520] 
	 nsEventQueueImpl::ProcessPendingEvents()
[nsEventQueue.cpp  line 374]  


COMMENTS/URLs:
 
     (37830464)	Comments: Quiting Netscape.
     (37779125)	Comments: I had changed the language per update from english to German  then
restartet NS. After I opened the Preferences/Settings menue  I tried to enlage
the screen  because there are not items visible - without success. When I closed
the setup dialog  NS crashes with error 2.
     (37749336)	Comments: Cheking my mail
     (37748742)	Comments: re-starting netscape after my previous crash  whilst filling in
this previous feedback form!
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash

Comment 1

17 years ago
The stack crawl says it's crashing after something in GIF2.cpp.  Changing
component to ImgLib.
Assignee: gordon → pavlov
Component: Networking: Cache → ImageLib
QA Contact: tever → tpreston
(Reporter)

Comment 2

17 years ago
changing topcrash bugs to critical
Severity: normal → critical
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Comment 3

16 years ago
nominating topcrash bugs for nsbeta1. 
Keywords: nsbeta1

Comment 4

16 years ago
updating summary with N621, since this continues to be topcrasher with Netscape
6.21:

 Count   Offset    Real Signature
[ 12   .__ptr_glue 34fd974d - output_row() ]
 
     Crash date range: 2002-01-12 to 2002-01-19
     Min/Max Seconds since last crash: 57 - 66679
     Min/Max Runtime: 57 - 873046
     Keyword List :  
     Count   Platform List 
     5   MacOS version 9.0.4  
     3   MacOS version 9.2.1  
     2   MacOS version 9.1  
     1   MacOS version 9.2.2  
     1   MacOS version 9.0.3  
 
     Count   Build Id List 
     12   2001113009
 
     No of Unique Users        12
 
 Stack trace(Frame) 

	 .__ptr_glue  
	 output_row()
[GIF2.cpp  line 198] 
	 do_lzw()
[GIF2.cpp  line 397] 
	 gif_write()
[GIF2.cpp  line 823] 
	 nsGIFDecoder2::ProcessData()
[nsGIFDecoder2.cpp  line 205] 
	 ReadDataOut()
[nsGIFDecoder2.cpp  line 153] 
	 nsInputStreamTee::WriteSegmentFun()
[nsInputStreamTee.cpp  line 78] 
	 nsPipe::ReadSegments()
[nsPipe2.cpp  line 411] 
	 nsInputStreamTee::ReadSegments()
[nsInputStreamTee.cpp  line 134] 
	 nsGIFDecoder2::WriteFrom()
[nsGIFDecoder2.cpp  line 220] 
	 imgRequest::OnDataAvailable()
[imgRequest.cpp  line 793] 
	 ProxyListener::OnDataAvailable()
[imgLoader.cpp  line 465] 
	 nsStreamListenerTee::OnDataAvailable()
[nsStreamListenerTee.cpp  line 56] 
	 nsHttpChannel::OnDataAvailable()
[nsHttpChannel.cpp  line 2224] 
	 nsOnDataAvailableEvent::HandleEvent()
[nsStreamListenerProxy.cpp  line 177] 
	 nsARequestObserverEvent::HandlePLEvent()
[nsRequestObserverProxy.cpp  line 64] 
	 PL_HandleEvent()
[plevent.c  line 590] 
	 PL_ProcessPendingEvents()
[plevent.c  line 520] 
	 nsEventQueueImpl::ProcessPendingEvents()
[nsEventQueue.cpp  line 374]  
 
     (1874180)	Comments: Quitting communicator
     (1663401)	Comments: signing out of netscape
     (1567560)	Comments: Quiting.
 
====================================================================================================
     Count   Offset    Real Signature
[ 10   .__ptr_glue f2e23514 - output_row() ]
 
     Crash date range: 2002-01-12 to 2002-01-21
     Min/Max Seconds since last crash: 11 - 40233
     Min/Max Runtime: 11 - 353603
     Keyword List :  
     Count   Platform List 
     6   MacOS version 9.2.2  
     3   MacOS version 9.1  
     1   MacOS version 9.2.1  
 
     Count   Build Id List 
     10   2001113009
 
     No of Unique Users         9
 
 Stack trace(Frame) 

	 .__ptr_glue  
	 output_row()
[GIF2.cpp  line 198] 
	 do_lzw()
[GIF2.cpp  line 397] 
	 gif_write()
[GIF2.cpp  line 823] 
	 nsGIFDecoder2::ProcessData()
[nsGIFDecoder2.cpp  line 205] 
	 ReadDataOut()
[nsGIFDecoder2.cpp  line 153] 
	 nsPipe::ReadSegments()
[nsPipe2.cpp  line 411] 
	 nsGIFDecoder2::WriteFrom()
[nsGIFDecoder2.cpp  line 220] 
	 imgRequest::OnDataAvailable()
[imgRequest.cpp  line 793] 
	 ProxyListener::OnDataAvailable()
[imgLoader.cpp  line 465] 
	 nsJARChannel::OnDataAvailable()
[nsJARChannel.cpp  line 600] 
	 nsOnDataAvailableEvent::HandleEvent()
[nsStreamListenerProxy.cpp  line 177] 
	 nsARequestObserverEvent::HandlePLEvent()
[nsRequestObserverProxy.cpp  line 64] 
	 PL_HandleEvent()
[plevent.c  line 590] 
	 PL_ProcessPendingEvents()
[plevent.c  line 520] 
	 nsEventQueueImpl::ProcessPendingEvents()
[nsEventQueue.cpp  line 374] 
	 NS_ShutdownXPCOM()
[nsXPComInit.cpp  line 492]  
 
     (1563678)	Comments: trying to load netscape

I know we're lacking good user comments and urls...but adding qawanted keyword
to see if we can get this reproduced with a recent milestone or MozillaTrunk build.
Keywords: qawanted
Summary: N620 crash [@ .__ptr_glue - output_row ] → N621 crash [@ .__ptr_glue - output_row ]
(Assignee)

Comment 5

16 years ago
cc'ing simon.  would this have been fixed by your earlier patches on the mac?
Target Milestone: Future → mozilla1.0
(Assignee)

Updated

16 years ago
Priority: -- → P2

Comment 6

16 years ago
can someone help reproduce this? 
per adt, not critical for nsbeta1. hence minus.
Keywords: nsbeta1 → nsbeta1-

Comment 7

16 years ago
We really don't have much talkback data on this crash.  The data I posted back
in comment #4 is the last set of info we have for N621 crashes and I don't see
any crashes like this in M098 or MozillaTrunk builds.  

Simon: If we know of a checkin that might have fixed this, then we can mark it
fixed.  Otherwise we should just make this worksforme if noone can reproduce it
with a recent build.

Comment 8

16 years ago
This could be related to bug 124767.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.1alpha

Comment 9

16 years ago
We should close out this bug in Bugzilla if the current trunk or 099 milestone
builds do not show this stack trace as a top crash.   

On a separate note, is this a topcrash for 6.22?  

Comment 10

16 years ago
seems to be working fine on build 4-08-2002, using win 98
Whiteboard: Non reproducible

Comment 11

16 years ago
I don't see more than just a couple of incidents reported for Netscape 6.23 and
Netscape 7.0 PR1 combined...so I'm going to mark this worksforme.  

If anyone is able to reproduce this at will with the stack signature and trace,
please feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
v.wfm for completeness.
Status: RESOLVED → VERIFIED
Crash Signature: [@ .__ptr_glue - output_row ]
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.