Recommended filtering seems off

VERIFIED FIXED in 2014-11-25

Status

Marketplace
Integration
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: andym, Assigned: robhudson)

Tracking

Avenir
2014-11-25
x86
Mac OS X
Points:
---

Details

(Reporter)

Description

3 years ago
I started a new profile, went to the recommended tab and got a list of apps. Some of them worked on Desktop, some didn't. That's cool.

https://www.dropbox.com/s/h9cm05qzee77ia2/Screenshot%202014-11-19%2014.36.30.png?dl=0

I then filtered by Desktop and got a slightly different list:

https://www.dropbox.com/s/cxq5hw01ntdmaoq/Screenshot%202014-11-19%2014.36.38.png?dl=0

But noted that Poppit is still there and that's not a Desktop app:

https://www.dropbox.com/s/9lbxhojxmiwruym/Screenshot%202014-11-19%2014.36.43.png?dl=0

Presumably I shouldn't get Poppit in this case.
(Reporter)

Updated

3 years ago
Assignee: nobody → robhudson.mozbugs
(Assignee)

Updated

3 years ago
Priority: -- → P2
(Assignee)

Comment 1

3 years ago
PR: https://github.com/mozilla/zamboni/pull/2743
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/zamboni/commit/0bca85d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-11-25

Comment 3

3 years ago
Verified in FF36(Win7) in marketplace-dev.allizom.org
The issue is still reproducing in mp-dev
Screenshot for this issue: http://screencast.com/t/quqABUAbuCi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

3 years ago
(In reply to Madalin Cotetiu from comment #3)
> Verified in FF36(Win7) in marketplace-dev.allizom.org
> The issue is still reproducing in mp-dev
> Screenshot for this issue: http://screencast.com/t/quqABUAbuCi

Ah, it seems like I got desktop wrong.

Can you verify FirefoxOS filters correctly on FxOS devices? And android mobile/tablet is working as expected? I'll fix desktop.
(Assignee)

Comment 5

3 years ago
Fixed: https://github.com/mozilla/zamboni/commit/1c27408
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 6

3 years ago
Verified as fixed in FF36(Win7, Android) FFOS 1.4 (Inari) and FFOS 2.0 (Flame)
Desktop: http://screencast.com/t/lwRQwv2mP
Android mobile: http://screencast.com/t/Hku8nUlxa1
Android tablet: http://screencast.com/t/81QPfjxXNt
FFOS 1.4: http://screencast.com/t/RkYirEUj3huq
FfOS 2.1: http://screencast.com/t/uEVsou8wDxfS
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.