Deal with removal of the plugin finder service.

RESOLVED FIXED in seamonkey2.34

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

Trunk
seamonkey2.34

SeaMonkey Tracking Flags

(seamonkey2.32 fixed, seamonkey2.33 fixed, seamonkey2.34 affected)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
Bug 836415 removed the PFS, so we shouldn't try to launch it.
(Assignee)

Updated

4 years ago
status-seamonkey2.32: --- → affected
status-seamonkey2.33: --- → affected
status-seamonkey2.34: --- → affected
(Assignee)

Comment 1

4 years ago
Created attachment 8525650 [details] [diff] [review]
Branch-safe patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8525650 - Flags: review?(philip.chee)
(Assignee)

Comment 2

4 years ago
Created attachment 8525652 [details] [diff] [review]
Remove strings on trunk
Attachment #8525652 - Flags: review?(philip.chee)

Comment 3

4 years ago
Comment on attachment 8525650 [details] [diff] [review]
Branch-safe patch

>              case nsIObjectLoadingContent.PLUGIN_UNSUPPORTED:
> -              // For broken non-object plugin tags, register a click handler so
> -              // that the user can click the plugin replacement to get the new
> -              // plugin. Object tags can, and often do, deal with that
> -              // themselves, so don't stomp on the page developer's toes.
> -              if (!(plugin instanceof HTMLObjectElement)) {
> -                // We don't yet check to see if there's actually an installer available.
> -                var installStatus = this.getPluginUI(plugin, "installStatus");
> -                installStatus.setAttribute("status", "ready");
> -                var iconStatus = this.getPluginUI(plugin, "icon");
> -                iconStatus.setAttribute("status", "ready");
> -                var installLink = this.getPluginUI(plugin, "installPluginLink");
> -                this.addLinkClickCallback(installLink, installMissingPlugins);
> -              }
> -
>                notification = "missing-plugins";
>                message = this._stringBundle.GetStringFromName("missingpluginsMessage.title");

Why do we even show a notification at all?

>       <handler event="NewPluginInstalled" phase="capturing">

This should be removed as nothing dispatches this event after Bug 836415.

https://hg.mozilla.org/mozilla-central/rev/d1ae4274cf8b#l6.30
>     6.30 -  ok(PopupNotifications.getNotification("plugins-not-found", gTestBrowser), "Test 1a, Should have displayed the missing plugin notification");
>     6.31 -  ok(gTestBrowser.missingPlugins, "Test 1a, Should be a missing plugin list");
>     6.32 -  ok(gTestBrowser.missingPlugins.has("application/x-unknown"), "Test 1a, Should know about application/x-unknown");
>     6.33 -  ok(!gTestBrowser.missingPlugins.has("application/x-test"), "Test 1a, Should not know about application/x-test");

Since we have plugin notification tests ported over from Firefox, we should fix out tests too.
Attachment #8525650 - Flags: review?(philip.chee) → review-

Updated

4 years ago
Attachment #8525652 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 4

4 years ago
Created attachment 8527251 [details] [diff] [review]
Branch-safe patch
Attachment #8527251 - Flags: review?
(Assignee)

Comment 5

4 years ago
Aargh, stupid Bugzilla, submitted when I didn't want to and even ignored what I'd already typed.
(Assignee)

Comment 6

4 years ago
Created attachment 8527252 [details] [diff] [review]
Branch-safe patch

a) Why not? But to make it more interesting I added a Preferences button.
   Since this is still branch-safe I reused an existing string.
b) Good catch, and I removed all of the missingPlugins logic too.
c) Tests don't need fixing because the notification is still there.
Attachment #8525650 - Attachment is obsolete: true
Attachment #8527251 - Attachment is obsolete: true
Attachment #8527251 - Flags: review?
Attachment #8527252 - Flags: review?(philip.chee)

Updated

4 years ago
Attachment #8527252 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 7

4 years ago
Comment on attachment 8527252 [details] [diff] [review]
Branch-safe patch

Pushed comm-central changeset 87542e9d358f.
(Assignee)

Comment 8

4 years ago
Comment on attachment 8525652 [details] [diff] [review]
Remove strings on trunk

Pushed comm-central changeset 2a6c7fda0caf.
(Assignee)

Comment 9

4 years ago
Comment on attachment 8527252 [details] [diff] [review]
Branch-safe patch

[Approval Request Comment]
Regression caused by (bug #): 836415
User impact if declined: Broken Install Plugins button
String changes made by this patch: None
Attachment #8527252 - Flags: approval-comm-beta?
Attachment #8527252 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #8527252 - Flags: approval-comm-beta?
Attachment #8527252 - Flags: approval-comm-beta+
Attachment #8527252 - Flags: approval-comm-aurora?
Attachment #8527252 - Flags: approval-comm-aurora+
(Assignee)

Comment 10

4 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/8d798926def3
http://hg.mozilla.org/releases/comm-beta/rev/919ddae9cf98
status-seamonkey2.32: affected → fixed
status-seamonkey2.33: affected → fixed
(Assignee)

Comment 11

4 years ago
Created attachment 8530674 [details] [diff] [review]
Create a separate string rather then reusing the existing string
Attachment #8530674 - Flags: review?(philip.chee)

Comment 12

4 years ago
Comment on attachment 8530674 [details] [diff] [review]
Create a separate string rather then reusing the existing string

This is for trunk right?
Attachment #8530674 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 13

4 years ago
Pushed comm-central changeset d26bc10d5d37.

(In reply to Philip Chee from comment #12)
> (From update of attachment 8530674 [details] [diff] [review])
> 
> This is for trunk right?

Right.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.34
You need to log in before you can comment on or make changes to this bug.