Closed Bug 1102115 Opened 5 years ago Closed 5 years ago

Android Tests fail with No tests run or test summary not found | runtestsremote.py: error: Please use --test-manifest only and not --run-only-test

Categories

(Testing :: Mochitest, defect)

x86
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cbook, Unassigned)

References

()

Details

Android 2.3 Emulator mozilla-inbound opt test mochitest-gl-1

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=4061111&repo=mozilla-inbound

19:06:28 INFO - runtestsremote.py: error: Please use --test-manifest only and not --run-only-tests
19:06:28 ERROR - No tests run or test summary not found
19:06:28 INFO - TinderboxPrint: mochitest-gl-1<br/><em class="testfail">T-FAIL</em>
19:06:28 INFO - ##### mochitest-gl-1 log ends
19:06:28 INFO - ##### test-1 emulator log begins
19:06:28 INFO - Reading from file /tmp/tmpxBCMPY
19:06:28 INFO - emulator: found SDK root at /tools/android-sdk18
19:06:28 INFO - emulator: Android virtual device file at: /home/cltbld/.android/avd/test-1.ini
19:06:28 INFO - emulator: /home/cltbld/.android/avd/test-1.ini: parsing as .ini file
19:06:28 INFO - emulator: 1: KEY='avd.ini.encoding' VALUE='ISO-8859-1'
19:06:28 INFO - emulator: 2: KEY='target' VALUE='android-10'
19:06:28 INFO - emulator: 3: KEY='path' VALUE='/home/cltbld/.android/avd/test-1.avd'
19:06:28 INFO - emulator: 4: KEY='path.rel' VALUE='avd/test-1.avd'
19:06:28 INFO - emulator: /home/cltbld/.android/avd/test-1.ini: parsing finished
19:06:28 INFO - emulator: virtual device content at /home/cltbld/.android/avd/test-1.avd
19:06:28 INFO - emulator: virtual device config file: /home/cltbld/.android/avd/test-1.avd/config.ini
19:06:28 INFO - emulator: /home/cltbld/.android/avd/test-1.avd/config.ini: parsing as .ini file
19:06:28 INFO - emulator: 1: KEY='hw.mainKeys' VALUE='no'
19:06:28 INFO - emulator: 2: KEY='hw.sensors.proximity' VALUE='yes'
19:06:28 INFO - emulator: 3: KEY='skin.dynamic' VALUE='yes'
19:06:28 INFO - emulator: 4: KEY='sdcard.size' VALUE='500M'
19:06:28 INFO - emulator: 5: KEY='hw.audioInput' VALUE='yes'
19:06:28 INFO - emulator: 6: KEY='skin.name' VALUE='1024x816'
19:06:28 INFO - emulator: 7: KEY='hw.dPad' VALUE='no'
19:06:28 INFO - emulator: 8: KEY='hw.ramSize' VALUE='1024'
19:06:28 INFO - emulator: 9: KEY='hw.accelerometer' VALUE='yes'
19:06:28 INFO - emulator: 10: KEY='hw.keyboard.lid' VALUE='yes'
19:06:28 INFO - emulator: 11: KEY='hw.camera.back' VALUE='none'
19:06:28 INFO - emulator: 12: KEY='hw.gpu.enabled' VALUE='yes'
19:06:28 INFO - emulator: 13: KEY='hw.sdCard' VALUE='yes'
jgriffin: Do you know who would be a good contact to cc here for investigation ?
OS: Mac OS X → Android
jlund, :kmoir could you take a look into this issue ?
Flags: needinfo?(kmoir)
Flags: needinfo?(jlund)
From the logs of mochitest-gl-1:

In the Successful job, we have:
--total-chunks=16 --run-only-tests=android23.json --this-chunk=1

In Intermittent Unsuccessful job:
--total-chunks=16 --run-only-tests=android23.json --this-chunk=1 --test-manifest=gl.json

So the --test-manifest is getting appended in the intermittent unsuccessful job which gives rise to the error. See: http://dxr.mozilla.org/mozilla-central/source/testing/mochitest/mochitest_options.py#531

IMO, this should be the cause of the problem.
Depends on: 1064002
Flags: needinfo?(kmoir)
Flags: needinfo?(jlund)
fixed by backout of bug 1064002
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.