Signal strength and Data signal (3G/H/E) is not changing while checking in after opening any app.

RESOLVED FIXED in 2.2 S13 (29may)

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: rishav_, Assigned: gmarty)

Tracking

({verifyme})

unspecified
2.2 S13 (29may)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 834023][systemsfe])

Attachments

(7 attachments)

Reporter

Description

5 years ago
Signal strength and Data signal (3G/H/E) is not changing (I observed this during journey in train when signal strength is varying) while checking in after opening any app.
When checking this in homescreen, it's fine but when i checked this after opening any app i got this.
I have attached the images.check the top line (near signal bar). We will find the difference.
Tested on Flame : Nightly
Reporter

Comment 1

5 years ago
Screen shot while checking it after opening any app
Do you remember if the time changed? We are investigating a bug where the whole status bar freezes.
Reporter

Comment 3

5 years ago
yeah..time too. Homescreen result is actual and correct .

Comment 4

4 years ago
Posted video statusbar_freeze.avi
Hi Gregor, has any progress been made on this? This issue is still occurring on v2.2, see attached video.

It's not 100% reproducible, but playing around with airplane mode and opening apps while it's being enabled/disabled seems to trigger this status bar freeze fairly regularly.
Flags: needinfo?(anygregor)

Updated

4 years ago
blocking-b2g: --- → 2.2?
Whiteboard: [CR 834023]
We fixed many issues around this. Was this reproduced on the latest 2.2 builds?
Flags: needinfo?(anygregor)
Flags: needinfo?(pgravel)
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(mhenretty)
Whiteboard: [CR 834023] → [CR 834023][systemsfe]
Whiteboard: [CR 834023][systemsfe] → [caf priority: p2][CR 834023][systemsfe]

Comment 6

4 years ago
Yes this is reproduced on latest 2.2 build.
Flags: needinfo?(pgravel)
Guillaume, can you take a look at this? Comment 4 seems to provide a starting point for STR.

We might need to land bug 1144126 to get more info from the reporter.
Assignee: nobody → gmarty
Flags: needinfo?(mhenretty) → needinfo?(gmarty)
Guillaume, can you make a patch like the one from bug 1144126, but with logging enabled by default. pgravel can apply this to their builds and get the logging results for us.
Assignee

Comment 9

4 years ago
Hi, this patch contains a logger for the status bar events. Can you please apply this patch to v2.2 branch and flash your phone?
Then try to reproduce the bug. When the bug is reproduced, please attach a logcat to this bug and I'll be able to enquire and see exactly what went wrong.
Flags: needinfo?(gmarty) → needinfo?(pgravel)

Comment 10

4 years ago

Updated

4 years ago
Flags: needinfo?(pgravel)

Comment 11

4 years ago
It took me some time to reproduce the issue. STR below

- Open email app
- Close the keyboard (not sure if that matters)
- Pull down the status bar and click on airplane mode icon
- Repeat above steps.
Hi Guillaume,
Soft reminder for the log provided by Anshul per comment 10.
Thank you!
Flags: needinfo?(gmarty)
Assignee

Comment 13

4 years ago
Thanks! I'm on it. I see exactly what goes wrong from the log. I'm now looking into how to reproduce and fix it.
Flags: needinfo?(gmarty)
Assignee

Comment 14

4 years ago
Simplified STR:
1. Open the utility tray
2. Quickly slide up the utility tray and push the home button at the same time

As a result, the utilitytraywillhide event will be triggered twice, resulting in an inconsistent behaviour.
Assignee

Comment 17

4 years ago
Comment on attachment 8608033 [details] [review]
[gaia] gmarty:Bug-1102183-Signal-strength-and-Data-signal-is-not-changing-while-checking-in-after-opening-any-app > mozilla-b2g:master

Etienne, here is a patch for you.
Attachment #8608033 - Flags: review?(etienne)
Comment on attachment 8608033 [details] [review]
[gaia] gmarty:Bug-1102183-Signal-strength-and-Data-signal-is-not-changing-while-checking-in-after-opening-any-app > mozilla-b2g:master

Comments on github, hope they're understandable :)
Attachment #8608033 - Flags: review?(etienne)
Assignee

Updated

4 years ago
Attachment #8608033 - Flags: review?(etienne)
Comment on attachment 8608033 [details] [review]
[gaia] gmarty:Bug-1102183-Signal-strength-and-Data-signal-is-not-changing-while-checking-in-after-opening-any-app > mozilla-b2g:master

r=me with the new test added (let me know if anything's unclear) and a new try build :)
Attachment #8608033 - Flags: review?(etienne) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed

Comment 20

4 years ago
Guillaume, this patch doesn't seem to be applying cleanly on v2.2. Is there a v2.2 version of this patch?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please rebase if needed and request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(gmarty)
Target Milestone: --- → 2.2 S13 (29may)
Assignee

Comment 24

4 years ago
Comment on attachment 8611136 [details] [review]
[gaia] gmarty:Bug-1102183-Signal-strength-and-Data-signal-is-not-changing-while-checking-in-after-opening-any-app-v2.2 > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Status bar monkey testing
[User impact] if declined: On some rare occasions, the status bar can freeze on its minimised state.
[Testing completed]: This patch has been thoroughly tested and has unit tests. Manual testing is good too.
[Risk to taking this patch] (and alternatives if risky): Low as changes are straightforward and we have unit tests.
[String changes made]: None
Flags: needinfo?(gmarty)
Attachment #8611136 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8611136 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.