Keypads should always be displayed in LTR, even in RTL mode

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: drs, Assigned: paco)

Tracking

unspecified
2.2 S1 (5dec)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 verified)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8526093 [details]
Screenshot

The keypad is shifted too far to the right and seems out of place in RTL. We should center it so that it is laid out the same way as in LTR. See attached screenshot.
(Reporter)

Updated

4 years ago
Target Milestone: --- → 2.2 S1 (5dec)
(Reporter)

Updated

4 years ago
Assignee: nobody → thills
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
(Reporter)

Updated

4 years ago
Assignee: thills → pacorampas
(Assignee)

Comment 1

4 years ago
Created attachment 8528235 [details] [review]
patch in github
(Assignee)

Comment 2

4 years ago
Created attachment 8528279 [details]
keypad-rtl-ltr.png
(Assignee)

Comment 3

4 years ago
Comment on attachment 8528235 [details] [review]
patch in github

Hi Doug,

Now, we are forcing the ltr keyboard in both scenarios (html dir: rtl and dir: ltr). Only one thing more, notice you that the buttons of bottom (add user button and call button) are changing with the direction change. So, I added a -moz-margin-start and now, the the code is working fine in both scenarios.

Thanks
Attachment #8528235 - Flags: review?(drs.bugzilla)
(Reporter)

Comment 4

4 years ago
Comment on attachment 8528235 [details] [review]
patch in github

Thanks Paco, this generally looks good. I left a few comments on the PR. Please address them before landing.

I'm also going to dupe bug 1011731 to this bug since it's fixed by this patch.

When you get a chance, please also make a demo and post it on the sprint demo page:
https://wiki.mozilla.org/FirefoxOS/Comms/Dialer/Sprint/v2.2-S1#Demos
Flags: needinfo?(pacorampas)
Attachment #8528235 - Flags: review?(drs.bugzilla) → review+
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1011731
(Reporter)

Updated

4 years ago
Summary: Keypad is shifted too far to the right → Keypads should always be displayed in LTR, even in RTL mode
(Assignee)

Comment 6

4 years ago
Created attachment 8528984 [details]
keypad-rtl-1099397.png
Flags: needinfo?(pacorampas)
(Assignee)

Comment 7

4 years ago
Hi Doug ,

I have uploaded the demo scheenshot into wiki as a link because i can't upload files. German Said me that he has a section "upload file" into the tools category, but I haven't this option. Could be a problem with my account privileges ?

Thanks
Flags: needinfo?(drs.bugzilla)
(Reporter)

Comment 8

4 years ago
(In reply to Paco Rampas [:paco] from comment #7)
> I have uploaded the demo scheenshot into wiki as a link because i can't
> upload files. German Said me that he has a section "upload file" into the
> tools category, but I haven't this option. Could be a problem with my
> account privileges ?

Yes, you have to have 10 edits before you're granted file upload permissions. See https://wiki.mozilla.org/MozillaWiki:News/2014-10/Changes_to_user_group_rights#What_rights_will_each_user_group_have_under_this_new_configuration.3F

To get to 10 edits, you can just edit your personal user page 10 times.

If you have more problems after that, see https://wiki.mozilla.org/MozillaWiki:News/2014-10/Changes_to_user_group_rights#Notice_any_issues.3F or let me know.
Flags: needinfo?(drs.bugzilla)
(Assignee)

Comment 9

4 years ago
merged: c86b2e4c2dac7e949e47953956746f632bbdcd71
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

3 years ago
Keywords: verifyme

Comment 10

3 years ago
According comment 3
The design is that forcing the ltr keyboard in both scenarios (html dir: rtl and dir: ltr). Only one thing more, notice you that the buttons of bottom (add user button and call button) are changing with the direction change.
This issue verified successfully on Flame2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/bccee1a13ba6
Build-ID        20150119002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Refer to picture 2015-01-19-04-10-51.png
Status: RESOLVED → VERIFIED
status-b2g-v2.2: --- → verified
Keywords: verifyme

Comment 11

3 years ago
Created attachment 8551595 [details]
2015-01-19-04-10-51.png
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.