If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Call log date headers don't cover the entire horizontal space

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: drs, Assigned: Nefzaoui)

Tracking

unspecified
2.2 S4 (23jan)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(7 attachments)

(Reporter)

Description

3 years ago
Created attachment 8526096 [details]
Screenshot

The call log date headers don't cover the entire horizontal space in RTL mode, so some of the call log items are shown on the far left.
(Reporter)

Updated

3 years ago
Target Milestone: --- → 2.2 S1 (5dec)
(Reporter)

Comment 1

3 years ago
The Messages team had the same problem in bug 1080820.
See Also: → bug 1080820
(Reporter)

Updated

3 years ago
Assignee: nobody → thills
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
(Reporter)

Comment 2

3 years ago
Created attachment 8530436 [details]
Screenshot 2

Here's a screenshot of a similar issue. The floating and static headers are misaligned. My guess is that we're applying margin/padding on one side and not the other.
(Assignee)

Comment 3

3 years ago
I'm not sure I fully understand the issue here? Doug, is this still occurring? If so could you please explain more?
I've compared RTL and LTR headers behavior and I don't see an existing issue in them.

Thanks!
Flags: needinfo?(drs.bugzilla)
(Assignee)

Comment 4

3 years ago
Update: found it. So my question here is if someone is working on this already?
Thanks
(Reporter)

Comment 5

3 years ago
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #4)
> Update: found it. So my question here is if someone is working on this
> already?
> Thanks

Nope, feel free to take it.
Flags: needinfo?(drs.bugzilla)

Comment 6

3 years ago
Created attachment 8542485 [details] [review]
[PullReq] anefzaoui:bug-1102325 to mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Comment on attachment 8542485 [details] [review]
[PullReq] anefzaoui:bug-1102325 to mozilla-b2g:master

The approach taken in SMS is quite good but it doesn't give a 100% accuracy of the position of sticky header, in fact if you look close enough to sticky in SMS, you'll see a margin of about 0.1rem either to left or right.
On the other hand, how does that look?
Thanks!
Attachment #8542485 - Flags: review?(drs.bugzilla)
(Reporter)

Comment 8

3 years ago
Comment on attachment 8542485 [details] [review]
[PullReq] anefzaoui:bug-1102325 to mozilla-b2g:master

Looks like the sticky header is about 1-2px right shifted from the static headers.
Attachment #8542485 - Flags: review?(drs.bugzilla) → review-
(Reporter)

Updated

3 years ago
Assignee: thills → nefzaoui
Target Milestone: 2.2 S1 (5dec) → 2.2 S3 (9jan)
(Assignee)

Comment 9

3 years ago
Created attachment 8547239 [details]
Screenshot - Patch Applied

It seems perfect.. Could you please look at the patch again? This is a screenshot of the patch applied.
Thanks!
Flags: needinfo?(drs.bugzilla)
(Reporter)

Updated

3 years ago
Flags: needinfo?(drs.bugzilla)
Attachment #8542485 - Flags: review- → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 10

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/47b15e583d04448bfa51e71a90e49ce94e0b5e7d

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 11

3 years ago
Hi Ahmed
This issue still exist on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate 0/5
Happen time 5:56
Description:The call log date headers don't cover the entire horizontal space in RTL mode, so some of the call log items are shown on the far left.
refer to logcat and video VIDEO0259_Compress.MP4.
Status: RESOLVED → REOPENED
status-b2g-v2.2: --- → affected
Flags: needinfo?(nefzaoui)
Resolution: FIXED → ---

Comment 12

3 years ago
Created attachment 8551187 [details]
VIDEO0259_Compress.MP4

Comment 13

3 years ago
Created attachment 8551188 [details]
logcat.txt
(Assignee)

Updated

3 years ago
Flags: needinfo?(nefzaoui)
This will be fixed in 2.2 once its uplifted, leaving a NI on :kaze to help with that.
Flags: needinfo?(fabien)
Flags: in-moztrap+
Comment on attachment 8542485 [details] [review]
[PullReq] anefzaoui:bug-1102325 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): ?
[User impact] if declined: messy/unreadable call log for RTL users
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): none — this is a trivial CSS update
[String changes made]: none
Flags: needinfo?(fabien)
Attachment #8542485 - Flags: approval-gaia-v2.2?(doliver)

Updated

3 years ago
Attachment #8542485 - Flags: approval-gaia-v2.2?(doliver) → approval-gaia-v2.2+
feature-b2g: --- → 2.2+
Priority: -- → P2
 Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15428/
Please don't reopen bugs unless the problem persists on master. It messes up the bug queries we use for uplifts.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-b2g-master: --- → fixed
Resolution: --- → FIXED
Target Milestone: 2.2 S3 (9jan) → 2.2 S4 (23jan)
v2.2: https://github.com/mozilla-b2g/gaia/commit/88108b783e4e2d2f1e6a8b5235b38fd09049229e
status-b2g-v2.2: affected → fixed

Comment 19

3 years ago
This issue has been verified successfully on Flame2.2/3.0.
Reproduce rate:0/5
Attachment:Verify_RTL_AM.mp4

Flame 2.2 build:

Gaia-Rev        d5a71cedb37dd45f439f672489db3994b349ac43
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/3094601af679
Build-ID        20150212010213
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150212.042740
FW-Date         Thu Feb 12 04:27:51 EST 2015
Bootloader      L1TC000118D0

Flame3.0:

Gaia-Rev        d5a71cedb37dd45f439f672489db3994b349ac43
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/3094601af679
Build-ID        20150212010213
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150212.042740
FW-Date         Thu Feb 12 04:27:51 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified

Comment 20

3 years ago
Created attachment 8564655 [details]
Verify_RTL_AM.MP4

Comment 21

3 years ago
(In reply to Coler from comment #19)
> This issue has been verified successfully on Flame2.2/3.0.
Update the build version:

Flame 3.0:

Build ID               20150214160203
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.194226
Firmware Date          Sat Feb 14 19:42:36 EST 2015
Bootloader             L1TC000118D0

Flame 2.2:

Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0
You need to log in before you can comment on or make changes to this bug.